Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: wifi unable to connect

  1. #1
    Join Date
    Aug 2012
    Beans
    21

    Question wifi unable to connect

    Hello there,
    I have a dell vostro 1014 Laptop, which runs a ubuntu 12.04. My wireless is enabled, but the LED doesnt glow and its also unable to find the connections nearby. When i was trying to sort out this issue with RTC, someone told me that it is an "rfkill soft-off" issue. Previously, someone told me that there are many interfaces created which is creating a problem for wifi. i am not sure, what that meant. Anyway, thats all i know about the problem. my wireless driver is an AR9285, by Atheros Communication Inc. Help me out guys!!

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,472
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: wifi unable to connect

    Please open a terminal and run and post:
    Code:
    lspci -nn | grep 0280
    rfkill list all
    dmesg | grep ath9
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Aug 2012
    Beans
    21

    Re: wifi unable to connect

    bravo@Roy-PC:~$ lspci -nn | grep 0280
    0c:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    bravo@Roy-PC:~$ rfkill list all
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: dell-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
    bravo@Roy-PC:~$ dmesg | grep ath9

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,472
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: wifi unable to connect

    bravo@Roy-PC:~$ dmesg | grep ath9
    Fascinating.

    Let's kick it a bit harder. Please run and post:
    Code:
    sudo modprobe ath9k
    dmesg | grep ath9
    iwconfig
    someone told me that it is an "rfkill soft-off" issue. Previously, someone told me that there are many interfaces created which is creating a problem for wifi. i am not sure, what that meant.
    It means a lot of people really don't know much.

    Other than the fact that the driver ath9k isn't loading on boot, so far, we see nothing unusual.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Aug 2012
    Beans
    21

    Re: wifi unable to connect

    Code:
    bravo@Roy-PC:~$ sudo modprobe ath9k
    [sudo] password for bravo: 
    WARNING: All config files need .conf: /etc/modprobe.d/blacklist, it will be ignored in a future release.
    WARNING: All config files need .conf: /etc/modprobe.d/ath9k.conf.save, it will be ignored in a future release.
    bravo@Roy-PC:~$ dmesg | grep ath9
    [ 1452.965130] ath9k 0000:0c:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [ 1452.965145] ath9k 0000:0c:00.0: setting latency timer to 64
    [ 1453.074186] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
    [ 1453.074927] Registered led device: ath9k-phy0
    bravo@Roy-PC:~$ iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11bgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on
              
    eth0      no wireless extensions.
    Thank you!

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,472
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: wifi unable to connect

    Hmmm, somebody has been busy! Let's unravel things. Please let me see:
    Code:
    cat /etc/modprobe.d/blacklist
    cat /etc/modprobe.d/ath9k.conf.save
    cat /etc/modprobe.d/ath9k.conf
    Let's fix those problems before we proceed.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Aug 2012
    Beans
    21

    Re: wifi unable to connect

    Code:
    bravo@Roy-PC:~$ cat /etc/modprobe.d/blacklist
    
    #Remove To Install MadWIFI Drivers
    blacklist ath9k
    blacklist ath5k
    
    #Remove To Install MadWIFI Drivers
    blacklist ath9k
    blacklist ath5k
    bravo@Roy-PC:~$ cat /etc/modprobe.d/ath9k.conf.save
    cat: /etc/modprobe.d/ath9k.conf.save: Permission denied
    bravo@Roy-PC:~$ cat /etc/modprobe.d/ath9k.conf
    cat: /etc/modprobe.d/ath9k.conf: No such file or directory
    bravo@Roy-PC:~$

  8. #8
    Join Date
    Aug 2012
    Beans
    21

    Re: wifi unable to connect

    and this MadWIFI thing was also suggested by some one. it didn't work either. I've been tied up with my wired connection on my laptop all day! relieve me brother! thank you!

  9. #9
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,472
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: wifi unable to connect

    bravo@Roy-PC:~$ cat /etc/modprobe.d/blacklist

    #Remove To Install MadWIFI Drivers
    blacklist ath9k
    blacklist ath5k

    #Remove To Install MadWIFI Drivers
    blacklist ath9k
    blacklist ath5k
    Fascinating. Did you try to install Madwifi? It seems that the driver you need is blacklisted, unless, of course, you've tried some other drivers.
    bravo@Roy-PC:~$ cat /etc/modprobe.d/ath9k.conf.save
    cat: /etc/modprobe.d/ath9k.conf.save: Permission denied
    Even more fascinating! How about:
    Code:
    sudo cat /etc/modprobe.d/ath9k.conf.save
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Aug 2012
    Beans
    21

    Re: wifi unable to connect

    Code:
    bravo@Roy-PC:~$ sudo cat /etc/modprobe.d/ath9k.conf.save
    [sudo] password for bravo: 
    options ath9k nohwcrypt=1
    bravo@Roy-PC:~$

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •