Soon, I'm buying Genius Easypen i405. I'm using Ubuntu 12.10. I don't know are they compatible. I googled a bit but only things I find are three years old. I can't be sure that they are correct in Quantal, so I would appreciate any information on compatibility.

Thanks in advance.