Results 1 to 1 of 1

Thread: Quantal Install on PPC iMac Gone Wrong

  1. #1
    Join Date
    Feb 2006
    Hatboro, PA
    Ubuntu Development Release

    Question Quantal Install on PPC iMac Gone Wrong

    I've recently needed to reimage my aged iMac G4 FlowerPot due to Debian Squeeze's PPC support not being really "up-to-date" enough for some of things I need to do. Needless to say, I was incredibly excited to see Quantal supports my architecture. My to my chagrin, I discovered my CDROM no longer functions on the machine, but thought to myself, "no big deal, I'll just USB boot." Well, any of you who have tried such a thing on a PPC iMac knows that's the dumbest thing I could have ever said or thought, as Odysseus had an easier time getting home than we have in usb-booting on PPC.

    Regardless, following Shawn Corey's excellent guide here and making a few of my own adjustments, I was able to do what I needed to and even could boot the install. Install itself goes swimmingly until setting-up the package installer (aka apt). No errors are thrown, but apt is not installed. I know this because when running a rescue and dropping into a root shell, there is no apt. I can continue running the installer and even reboot the machine, but I run into the display error related to not having xserver-xorg-video-nouveau installed.

    And now you see my issue... I need to apt-get the nouveau and can't because apt isn't installed.

    I'm stuck. Help?

    I've been able to get around my previous problem with apt-install, a program I knew nothing about, but which--apparently--acts as apt inside of the installer. From there, I was able to install the things I thought I needed and rebooted; however, I'm without a graphical startup. I tried the fixes mentioned in this thread to no avail. I'm sure it's because Quantal handles xorg differently, but I'm not sure how. I seem to remember reading an article about why xorg.conf was being removed, but can't remember where I saw it. New help?
    Last edited by moore.bryan; September 3rd, 2012 at 12:38 PM. Reason: Developments
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu GNOME 14.10 Utopic Unicorn | Apple iMac G4: Ubuntu 12.04 Precise Pangolin | LG Optimus F3: Stock v7 | Nexus 10 Cyanogenmod 11

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts