Results 1 to 3 of 3

Thread: [Solved] Intel Wireless-N 2230 Ubuntu 10.04

  1. #1
    Join Date
    Dec 2012

    [Solved] Intel Wireless-N 2230 Ubuntu 10.04

    Hi there, I'm going to post my solution for getting Intel Wireless-N 2230 to work under Ubuntu 10.04.

    First of all, I started trying the solution posted here as follows:

    sudo su
    make clean
    ./scripts/driver-select restore
    ./scripts/driver-select iwlwifi
    make install
    And this was the result after rebooting and "sudo modprobe iwlwifi":
    (It doesn't work, and no rfkill output. The device seems to wake up but then, for no apparent reason, it gets disabled. I write this just in case the image link gets eventually broken).

    So finally I had to try this drivers iwlwifi-2030-ucode-
    All you have to do is:
    1-Extract them at /lib/firmware. It will create a folder named "iwlwifi-2030-ucode-18-168.6.1".
    2-Inside that folder you will find "iwlwifi-2030-6.ucode". Copy that file into /lib/firmware
    Reload drivers:
    3-sudo modprobe -r iwlwifi
    4-sudo modprobe iwlwifi
    It should be working now.

    I hope it helps.

    Have a nice day.

  2. #2
    Join Date
    Aug 2005
    South Carolina, USA
    Ubuntu 16.04 Xenial Xerus

    Re: [Solved] Intel Wireless-N 2230 Ubuntu 10.04

    First of all, Ubuntu 10.04 is beyond its use-by date: If it were me, I'd upgrade to 12.04 and I'm quite sure your 2230 would be working with no extra steps.

    Second, as with many devices, Intel wireless cards are almost all covered by one driver. It is iwlagn in 10.04 and iwlwifi in later Ubuntu versions. The specifics of how to drive a specific device, your 2230 or my 6200 for example, are included in the firmware. Intel calls their firmware ucode:
    In your case, simply installing the matching firmware solved your case.

    Now that you have a working wireless connection, I urge you to download and install 12.04.3 LTS.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Dec 2012

    Re: [Solved] Intel Wireless-N 2230 Ubuntu 10.04

    Thanks for the reply, but the weird thing is that I have got another laptop with the same wireless card and I tried the first solution (compat-wireless- and it worked as it did here...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts