Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: wireless issues with WPA2 due to distance

  1. #1
    Join Date
    Oct 2010
    Beans
    29

    [SOLVED]wireless issues with WPA2 due to distance

    Went back to school and found that my "new" (to me anyway) laptop can't connect to wifi. It works if it's close to the router but past 30 or so feet it doesn't pick it up. Apparently I have the same issue in my house, I just didn't notice because it's much smaller (though because I've been messing with it so much it has stopped working unless I'm in the same room as the router) than a big university.

    Some info if needed:

    Code:
    sudo lshw -C network
    [sudo] password: 
      *-network               
           description: Ethernet interface
           product: 82566MM Gigabit Network Connection
           vendor: Intel Corporation
           physical id: 19
           bus info: pci@0000:00:19.0
           logical name: eth0
           version: 03
           serial: 00:1d:72:8e:26:f7
           capacity: 1Gbit/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=1.5.1-k firmware=0.3-0 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:42 memory:f8200000-f821ffff memory:f8225000-f8225fff ioport:1840(size=32)
      *-network
           description: Wireless interface
           product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: wlan0
           version: 61
           serial: 00:13:e8:a3:95:03
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwl4965 driverversion=3.2.0-29-generic-pae firmware=228.61.2.24 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
           resources: irq:44 memory:f7f00000-f7f01fff
    ubuntux61tablet:~$ iwconfig
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11abgn  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              
    eth0      no wireless extensions.
    
    ubuntux61tablet:~$
    Last edited by Oxyris; August 28th, 2012 at 10:14 PM.

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,891
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless issues with WPA2 due to distance

    Please open a terminal and do:
    Code:
    sudo modprobe -r iwl4965
    sudo modprobe iwl4965 11n_disable=1
    Any improvement?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Oct 2010
    Beans
    29

    Re: wireless issues with WPA2 due to distance

    Quote Originally Posted by chili555 View Post
    Please open a terminal and do:
    Code:
    sudo modprobe -r iwl4965
    sudo modprobe iwl4965 11n_disable=1
    Any improvement?
    Yes, it started working almost immediately. I'll check to make sure it's working in different buildings and then I'll modify the prefix. Thank you.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,891
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless issues with WPA2 due to distance

    then I'll modify the prefix.
    How so? There is a right, effective way to do it. What are you planning?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Oct 2010
    Beans
    29

    Re: wireless issues with WPA2 due to distance

    Quote Originally Posted by chili555 View Post
    How so? There is a right, effective way to do it. What are you planning?
    I meant change the title of the post to solved. Sorry for the confusion.


    P.S. I'm not usually a technical user but if you don't mind, could you explain what I just did to my computer?
    Last edited by Oxyris; August 28th, 2012 at 10:15 PM.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,891
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless issues with WPA2 due to distance

    You asked that the wireless driver iwlwifi be removed and then be reloaded with a parameter '11n_disable.' As you might see, it disables N speed capability. It is the subject of a long-standing bug.

    What I was driving at is that the parameter disappears on reboot unless you take steps to make it persistent, which I assume you want. Please open a terminal and do:
    Code:
    sudo gedit /etc/modprobe.d/iwlwifi.conf
    Add a single line:
    Code:
    options iwlwifi 11n_disable=1
    Proofread, save and close gedit. If you don't have the text editor gedit, use leafpad, kate or any other text editor.

    You should be all set.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Oct 2010
    Beans
    29

    Re: wireless issues with WPA2 due to distance

    To make sure: I rebooted my computer earlier am I supposed to
    Code:
    sudo modprobe -r iwl4965
    sudo modprobe iwl4965 11n_disable=1
    Then do this
    Code:
    sudo gedit /etc/modprobe.d/iwlwifi.conf
    Or can I get away with just starting at the second part?

  8. #8
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,891
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless issues with WPA2 due to distance

    Once you have written the file /etc/modprobe.d/iwlwifi.conf, then the driver parameter will be loaded automatically with no further action on your part. Once it's written, reboot and you are permanently all done.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #9
    Join Date
    Oct 2010
    Beans
    29

    Re: wireless issues with WPA2 due to distance

    Quote Originally Posted by chili555 View Post
    Once you have written the file /etc/modprobe.d/iwlwifi.conf, then the driver parameter will be loaded automatically with no further action on your part. Once it's written, reboot and you are permanently all done.
    Well, it was working and now it's not. I'll see what else I can do to fix it but thanks a bunch for your help.

  10. #10
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    22,891
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: wireless issues with WPA2 due to distance

    Let's be sure there are no typos in the file:
    Code:
    cat /etc/modprobe.d/iwlwifi.conf
    Let's also see if the parameter got accepted:
    Code:
    cat /sys/module/iwlwifi/parameters/11n_disable
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •