Results 1 to 5 of 5

Thread: 12.04 Capture Firewire DV

  1. #1
    Join Date
    Aug 2007
    Ubuntu 12.04 Precise Pangolin

    12.04 Capture Firewire DV

    I'm trying to get my Canon HV20 to connect to Kino so that I can get my videos off of it. I'm having all sorts of problems.

    I finally have Kino recognizing the fw0 device, but then it can't seem to recognize my camera.

    grep 1394 /var/log/kern.log
    Aug 26 21:45:46 james-G50VT kernel: [    0.301394] system 00:08: Plug and Play ACPI device, IDs PNP0c02 (active)
    Aug 26 21:50:30 james-G50VT kernel: [    0.301394] system 00:08: [mem 0xfed45000-0xfed89fff] has been reserved
    Does this mean that the kernel doesn't recognize the firewire port?

    07:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
    From what I can tell here, it sees the device.

    To get Kino to recognize fw0, I had to link it to /dev/raw1394.

    Doing so fixed my
    WARNING: raw1394 kernel module not loaded or failure to read/write /dev/raw1394!
    error. But now I get
    No AV/C compliant cam connected or not switched on?
    I'm running out of ideas and all the solutions online are either dated from 2008 or still go unsolved.

    I'm running Ubuntu 12.04 LTS 64 bit on an Asus G50V, with a Canon HV20 Camcorder. I've tried Kino and dvGrab, neither seem to be able to recognize my camera.

    Any help would be tremendously appreciated.

  2. #2
    Join Date
    Apr 2006

    Re: 12.04 Capture Firewire DV

    I'm trying to solve more or less similar problem myself: Ubuntu recognizes the Firewire adapter but nothing happens when I connect the camera, only disconnecting is shown in dmesg.

    Does you dmesg show something when you connect the camera? It will help solve the problem and show if the camera is correctly recognized.


  3. #3
    Join Date
    Jun 2010

    Re: 12.04 Capture Firewire DV

    I am also struggling with exactly the same problem..

    ~$ lspci | grep 1394
    02:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 80)

    $ lsmod | grep -e 1394 -e firewire
    firewire_ohci 40180 0
    firewire_core 56906 7 firewire_ohci
    crc_itu_t 12627 1 firewire_core

    Quite evidently, Linux has identified and registered the device, and loaded the drivers, but Kino still says "No AV/C compliant cam connected or switched on?"

  4. #4
    Join Date
    Aug 2007

    Re: 12.04 Capture Firewire DV

    I had the same problem, and nothing seemed to work. Finally, my cable got unplugged, and when I plugged it back it all suddenly worked...

    For as silly as it may seem, try unplugging the Firewire cable, and plug it back again WITH kino running. Kino displays a message at the bottom and suddenly all starts working correctly (including camera controlling and capturing).

  5. #5
    Join Date
    Apr 2007
    Ubuntu 11.10 Oneiric Ocelot

    Re: 12.04 Capture Firewire DV

    The same thing happened to me and following gioachin's advice worked!
    HD 1T SAMSUNG HD103SI, VGA SAPPHIRE HD4670, MB GIGABYTE GA-H55-USB3, MEM 2Gx2 GSKILL, CPU INTEL I3 3.06G, QuickCam Communicate MP, Hauppauge PVR150


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts