Results 1 to 1 of 1

Thread: xinit and alsa (premissions problem?)

  1. #1
    Join Date
    May 2011

    Cool xinit and alsa (permissions problem?)


    I have a ubuntu-minimal installation, running xserver and dolphin-emu (nintendo wii-emulator).

    The problem that i have is, that if the emulator runs without root-permissons the sound (alsa-backend) is not working...

    that means if i run:

    xinit dolphin-emu
    ---> no sound

    but if i do:

    and from another terminal:

    export DISPLAY=:0
    sudo /usr/games/dolphin-emu
    ---> everything works as aspected!

    I do not think that my alsa configuration causes problems, because it works if the emu runs as root.

    my user is in the audio group.

    i also noticed another strange thing which might be helpful for finding the solution:

    if i run xinit with any other application, for example:

    xinit firefox
    i do not have sound even if i run the emu as root.

    i figured out that the only working case is:

    (without parameter)

    and than run the emu as root as shown before...

    I hope somebody can at least point me to the right direction as i do not have any idea how to fix that behaviour.
    Last edited by Skystriker; August 25th, 2012 at 05:41 PM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts