Results 1 to 2 of 2

Thread: Installing KGpg and gpgdir (to encrypt directories)

  1. #1
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Installing KGpg and gpgdir (to encrypt directories)

    I'm still using Ubuntu 10.10

    installed KGpg
    got it to work and manage key in the GUI

    then installed gpgdir (to encrypt directories)

    http://www.ghacks.net/2009/06/03/rec...s-with-gpgdir/

    this installation does not fully work yet

    this error is shown ..

    /usr/bin/perl: symbol lookup error: /usr/lib/gpgdir/i386-linux-thread-multi/auto/Class/MethodMaker/MethodMaker.so: undefined symbol: Perl_Tstack_sp_ptr

    test file shows the above error.

    but when I go back to launch KGpg it will not launch the agent.

    So neither KGpg or gpgdir is working. KGpg seemed to stop launching after I installed gpgdir (but that might be coincidence).

    Any advice?


    [1st Edit]

    I can now launch kgpg from command line

    kgpg -d

    Options:
    -e Encrypt file
    -k Open key manager
    -d Open editor
    -s Show encrypted file
    -S Sign file
    -V Verify signature


    But will not launch from Applications menu.

    And gpgdir still refuses to work.


    [2nd Edit]


    The KGpg problem is solved.

    I went into Applications (right click) > Edit Menus

    and changed the properties of KGpg link

    from kgpg %U
    to kgpg -d
    which launches editor

    So it is gpgdir perl error above which remains to be solved.


    Last edited by dragonfly41; August 24th, 2012 at 09:55 PM. Reason: update ..

  2. #2
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Installing KGpg and gpgdir (to encrypt directories)

    gpgdir problem solved.

    The developer of gpgdir (Michael Rash) suggested

    • installing libclass-methodmaker-perl package (Synaptic Package Manager)
    • delete old installation files in /usr/lib/gpgdir
    • reinstall from gdrdir source with "./install.pl --Exclude Maker"

    and this worked .. all tests in test suite passed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •