Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Wesnoth

  1. #1
    Join Date
    Jul 2008
    Beans
    90

    Wesnoth

    I attempt to launch Wesnoth, and I recieve the following error:

    Battle for Wesnoth v1.10.3
    Started on Tue Aug 21 19:23:31 2012

    20120821 19:23:31 error display: Could not initialize SDL_video: No available video device
    Could not initialize video. Exiting.


    Could someone tell me how to fix this?

  2. #2
    Join Date
    Aug 2009
    Beans
    1,419

    Re: Wesnoth

    It would be helpful if you described your hardware, the version of Ubuntu you are running, etc.

  3. #3
    Join Date
    Mar 2012
    Location
    New Hampshire, USA
    Beans
    Hidden!
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Wesnoth

    Did a search and found a similar hit via Google here:

    http://ubuntuforums.org/showthread.php?t=944671
    (It's an old topic but...)

    There seems to be a fix for 12.04, assuming your are running the latest version:

    http://ubuntuforums.org/showpost.php...16&postcount=5

  4. #4
    Join Date
    Jul 2008
    Beans
    90

    Re: Wesnoth

    Running a Dell Inspiron N5050 with Ubuntu 12.04

  5. #5
    Join Date
    Jul 2008
    Beans
    90

    Re: Wesnoth

    Quote Originally Posted by synaptix View Post
    Did a search and found a similar hit via Google here:

    http://ubuntuforums.org/showthread.php?t=944671
    (It's an old topic but...)

    There seems to be a fix for 12.04, assuming your are running the latest version:

    http://ubuntuforums.org/showpost.php...16&postcount=5
    Didn't work. It would not allow me to run the "sudo apt-get remove libsdl1.2debian" command. I got stuck with the error of:

    sudo apt-get remove libsdl
    libsdl1.2debian libsdl-image1.2 libsdl-net1.2 libsdl-perl libsdl-ttf2.0-0
    libsdl-gfx1.2-4 libsdl-mixer1.2 libsdl-pango1 libsdl-sound1.2
    justin@beastjr:~$ sudo apt-get remove libsdl1.2debian
    [sudo] password for justin:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    testdrive-common : Depends: qemu-kvm but it is not going to be installed or
    kvm (>= 1:84+dfsg-0ubuntu12.4) or
    virtualbox-ose (>= 3.1.6) but it is not going to be installed or
    virtualbox-3.1 but it is not installable or
    virtualbox-3.2 but it is not installable or
    virtualbox-4.0 but it is not installable
    Recommends: kvm-pxe but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

  6. #6
    Join Date
    Aug 2009
    Beans
    1,419

    Re: Wesnoth

    Quote Originally Posted by TNAFan View Post
    Didn't work. It would not allow me to run the "sudo apt-get remove libsdl1.2debian" command. I got stuck with the error of:

    sudo apt-get remove libsdl
    libsdl1.2debian libsdl-image1.2 libsdl-net1.2 libsdl-perl libsdl-ttf2.0-0
    libsdl-gfx1.2-4 libsdl-mixer1.2 libsdl-pango1 libsdl-sound1.2
    justin@beastjr:~$ sudo apt-get remove libsdl1.2debian
    [sudo] password for justin:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    testdrive-common : Depends: qemu-kvm but it is not going to be installed or
    kvm (>= 1:84+dfsg-0ubuntu12.4) or
    virtualbox-ose (>= 3.1.6) but it is not going to be installed or
    virtualbox-3.1 but it is not installable or
    virtualbox-3.2 but it is not installable or
    virtualbox-4.0 but it is not installable
    Recommends: kvm-pxe but it is not installable
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Those warnings aren't about the removal of sdl, they mean you have other broken packages. What happens when you type the following in a terminal?
    Code:
    sudo apt-get update

  7. #7
    Join Date
    Jul 2008
    Beans
    90

    Re: Wesnoth

    Fetched 1,815 kB in 1min 15s (23.9 kB/s)
    Reading package lists... Done
    justin@beastjr:~$


    No errors.

  8. #8
    Join Date
    Aug 2009
    Beans
    1,419

    Re: Wesnoth

    How about
    Code:
    sudo apt-get upgrade

  9. #9
    Join Date
    Aug 2009
    Beans
    1,419

    Re: Wesnoth

    How did you install Battle of Wesnoth? Did you get it from the Ubuntu Software Center?

  10. #10
    Join Date
    Jul 2008
    Beans
    90

    Re: Wesnoth

    Quote Originally Posted by thatguruguy View Post
    How about
    Code:
    sudo apt-get upgrade
    No errors.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •