Results 1 to 7 of 7

Thread: 12.10 : performance extremely choppy after udpate!

  1. #1
    Join Date
    Feb 2010
    Beans
    4

    Red face 12.10 : performance extremely choppy after udpate!

    Hi guys,

    got something called kworker eating up CPU time and stuttering every 5 or so seconds after doing an update on a brand new installation of 12.10, I remember downloading the software updates, applying, then installing XBMC, restarting, then boom, choppy heaven! It's pretty unusable, a shame, ran so nicely prior to the update..

    Any general fixes I can try? Surely I can't be the only one? Currently using an i5 processor.


  2. #2
    Join Date
    Feb 2010
    Beans
    4

    Re: 12.10 : performance extremely choppy after udpate!

    I updated form the official updates, only switched to non-official after the incident, that still didn't help, why would official updates judo chop my OS like this?

  3. #3
    Join Date
    Mar 2005
    Location
    UK
    Beans
    562

    Re: 12.10 : performance extremely choppy after udpate!

    What graphics card are you using and what driver?

    If its AMD or Nvidia are you using the accelerated OpenGL driver?

  4. #4
    Join Date
    Feb 2010
    Beans
    4

    Re: 12.10 : performance extremely choppy after udpate!

    Quote Originally Posted by hal8000 View Post
    What graphics card are you using and what driver?

    If its AMD or Nvidia are you using the accelerated OpenGL driver?
    Hi Hal, ATI 5850, but did not install any drivers, it was literally a new installation to a new partition, some fooling around, hitting the update button, rebooting, and finding myself on stutter island.

  5. #5
    Join Date
    Feb 2010
    Beans
    4

    Re: 12.10 : performance extremely choppy after udpate!

    Could it be that when I did the normal update the first time, my ATI's drivers were also downloaded? I just want to attach this issue to a trend, because of the fact that this was a new installation, I refuse to believe other people aren't experiencing the same issues?

  6. #6
    Join Date
    Mar 2005
    Location
    UK
    Beans
    562

    Re: 12.10 : performance extremely choppy after udpate!

    What you might need to do is check that you are using the acceleated driver:

    lsmod | grep fglrx


    Should return a match, if not see this post and install kernel headers and
    ati driver

    http://ubuntuforums.org/showthread.php?t=2075783

    Hope that helps.

  7. #7
    Join Date
    Apr 2007
    Beans
    4

    Re: 12.10 : performance extremely choppy after udpate!

    I have similar situation on 12.10 after upgrade from previous version. Kworker is just eating 100% from one of the CPU cores. I'm not sure what can cause this.
    Using perf record I'm getting:
    Code:
    +  46,65%  kworker/0:2  [kernel.kallsyms]  [k] native_read_tsc                                                                                                             ◆
    +  39,08%  kworker/0:2  [kernel.kallsyms]  [k] delay_tsc                                                                                                                   ▒
    +   6,48%  kworker/0:2  [kernel.kallsyms]  [k] acpi_os_read_port                                                                                                           ▒
    +   4,38%  kworker/0:2  [kernel.kallsyms]  [k] acpi_ec_gpe_handler                                                                                                         ▒
    +   1,84%  kworker/0:2  [kernel.kallsyms]  [k] acpi_os_write_port                                                                                                          ▒
    +   0,27%  kworker/0:2  [kernel.kallsyms]  [k] acpi_ec_transaction_unlocked
    Any ideas where to look further?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •