Results 1 to 3 of 3

Thread: Grub2 keeps ignoring default setting

  1. #1
    Join Date
    May 2011

    Grub2 keeps ignoring default setting

    I used to have an issue with Grub2 ignoring my default OS to boot but changed /etc/default/grub to:

    GRUB_DEFAULT="Windows 7 (loader) (on /dev/sdb1)"

    as per this thread I was involved in:

    I had to reinstall Win7 a few months back and tonight used boot-repair to reinstall grub.

    My Mythbuntu was the default. I made the above change and it was still Mythbuntu. did the GRUB_DEFAULT="Windows 7 (loader) (on /dev/sdb1)" and sudo update-grub and it was still mythbuntu.


  2. #2
    Join Date
    Nov 2009
    Mataro, Spain
    Ubuntu 14.04 Trusty Tahr

    Re: Grub2 keeps ignoring default setting

    Do you have only one version of Mythbuntu and one version of windows?

    Is the win7 recognized correctly after the reinstallation and restoring grub2? I assume it can boot OK?

    Is the spelling of the menu entry exactly as the detected one?

    Alternatively you can just use the number instead of the title. Don't forget it starts counting from 0. If the win7 entry is fifth for example, set it to 4 and it should be OK.

    These days the entries don't move often even after kernel updates since the first time you do kernel update it creates an entry called Previous Versions and after that it puts all older kernels inside making all the other boot entries stay fixed without moving around.
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  3. #3
    Join Date
    Jan 2008
    Ubuntu Development Release

    Arrow Re: Grub2 keeps ignoring default setting

    please indicate your Boot-Info URL.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts