Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Ubuntu won't boot when cloned onto identical machine.

  1. #11
    Join Date
    Apr 2011
    Beans
    25

    Re: Ubuntu won't boot when cloned onto identical machine.

    Both systems have identical BIOS settings and both boot using EFI. They are all fresh from the factory and out of the box.

    I don't know much about EFI. Does it use the UUID in some way and that's what is wrong?

  2. #12
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu won't boot when cloned onto identical machine.

    If you go into UEFI menu does it show the drive?

    Then does it show the efi menu of systems to boot?

    Someone posted this one their UEFI, but every vendor's UEFI menu is different.

    Enter your UEFI menu, select "Boot maintenance manager", then "Boot options", then "Add boot option", then "NO VOLUME LABEL,....Primary,Slave...1, GPT,..", then browse the /EFI/ubuntu/ folder via the UEFI boot menu, and select the grubx64.efi . Give it the name you want (eg "Precise"), then "Commit Changes and exit", then Enter.

    You be able to read efi partition from UEFI and it should show Ubuntu/grub as a choice to boot.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #13
    Join Date
    Apr 2011
    Beans
    25

    Re: Ubuntu won't boot when cloned onto identical machine.

    The Boot menu does show the drive (on machine B). However it is not in the 'EFI Boot Sources', it is under 'Legacy Boot Sources'. It is labeled 'ST500DM002' (the name of the HDD). When I choose the drive it does not boot, same as above.

    On machine A, in the boot menu under EFI Boot Sources, it says 'ubuntu'. Booting to it works. 'ST500DM002' Also shows up in 'Legacy Boot Sources'.
    Last edited by acpuck1; August 10th, 2012 at 05:45 PM.

  4. #14
    Join Date
    Apr 2011
    Beans
    25

    Re: Ubuntu won't boot when cloned onto identical machine.

    So I guess my problem is that ubuntu isn't showing as EFI bootable on any other machines.

  5. #15
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu won't boot when cloned onto identical machine.

    The legacy boot would be the BIOS boot from the MBR. If just installed to efi partition then you should not have anything in the MBR.

    If you plug in a USB flash with the efi boot partition on the non-working one does it at least show the flash drive as efi bootable?

    Not that I think it will show anything run the BootInfo report from Boot-Repair.

    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration an diagnose advanced problems.

    If it works on one system, report should show all normal entries.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #16
    Join Date
    Apr 2011
    Beans
    25

    Re: Ubuntu won't boot when cloned onto identical machine.

    It shows the flash drive as Legacy.

    On a hunch I installed Ubuntu 10.10 and it works on both machines A and B.

    Thanks everyone for their help.

  7. #17
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Ubuntu won't boot when cloned onto identical machine.

    Even if booting in BIOS mode you may want to format to gpt and create the efi partition as well as the bios_grub partitions. The efi partition has to be first and would give you the flexibility to change to UEFI booting in the future. But if always imaging drives then it will not matter.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  8. #18
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,974
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Ubuntu won't boot when cloned onto identical machine.

    i have 10 identical machines and what caused trouble is you have to change to correct host name in 2 files I forget which files each computer has it's own name usually

  9. #19
    Join Date
    Apr 2011
    Beans
    25

    Re: Ubuntu won't boot when cloned onto identical machine.

    Haha, I knew it had to be something this simple. Thanks a lot!

  10. #20
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Ubuntu won't boot when cloned onto identical machine.

    Quote Originally Posted by cmcanulty View Post
    i have 10 identical machines and what caused trouble is you have to change to correct host name in 2 files I forget which files each computer has it's own name usually
    /etc/hostname and /etc/hosts
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •