Results 1 to 8 of 8

Thread: SMTP mail server

  1. #1
    Join Date
    Mar 2012
    Beans
    189

    SMTP mail server

    I have mail server userid , password of a remote SMTP mail server. ( 625 port)
    I also have mail sender ID.



    I want to check whether remote SMTP mail server is working or not.

    How do I check that SMTP server can send email to recipients from my ubuntu box?

    I have ubuntu server 10 OS ( no GUI)
    Last edited by winzip; August 9th, 2012 at 09:38 AM.

  2. #2
    Join Date
    Apr 2006
    Location
    Adelaide, Australia
    Beans
    815
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: SMTP mail server

    Check out this site for a simple process to check the response of a remote smtp server.

    http://www.simplescripts.de/smtp-che...et-command.htm
    "Strive to be the person your dog thinks you are"

  3. #3
    Join Date
    Mar 2012
    Beans
    189

    Re: SMTP mail server

    Quote Originally Posted by HereInOz View Post
    Check out this site for a simple process to check the response of a remote smtp server.

    http://www.simplescripts.de/smtp-che...et-command.htm
    port is 465 ( The site deals with port 25....)

    How do I send email for port 465?

  4. #4
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: SMTP mail server

    Just replace 25 with 465 in the initial telnet command.
    Cheesemill

  5. #5
    Join Date
    Mar 2012
    Beans
    189

    SMTP failed

    SMTP failed in command line ...

    Can you please tell what could be the issue ?

    Here I'm trying to connect a remote SMTP mail server running at 465 port

    user@user:~$ telnet xxx.xxx.x.x 465
    Trying xxx.xxx.x.x...
    Connected to xxx.xxx.x.x.
    Escape character is '^]'.

    helo xxx.xxx.x.x
    Connection closed by foreign host.


    (For security reason I have masked the IP)

    Can you please tell what is the issue ? I see telnet is working ...that means SMTP mail server is running

    .....then why helo command fails ? Where is the problem ? How do I troubleshoot ?
    Last edited by winzip; August 10th, 2012 at 12:09 PM.

  6. #6
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: SMTP failed

    Quote Originally Posted by winzip View Post
    SMTP failed in command line ...

    Can you please tell what could be the issue ?

    Here I'm trying to connect a remote SMTP mail server running at 465 port

    user@user:~$ telnet xxx.xxx.x.x 465
    Trying xxx.xxx.x.x...
    Connected to xxx.xxx.x.x.
    Escape character is '^]'.

    helo xxx.xxx.x.x
    Connection closed by foreign host.


    (For security reason I have masked the IP)

    Can you please tell what is the issue ? I see telnet is working ...that means SMTP mail server is running .....then why helo command fails ? Where is the problem ? How do I troubleshoot ?
    As far as I know port 465 is used for secure connections, so you cannot talk in plain text.

  7. #7
    Join Date
    Mar 2006
    Location
    Brighton, UK
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: SMTP failed

    Quote Originally Posted by albandy View Post
    As far as I know port 465 is used for secure connections, so you cannot talk in plain text.
    Correct.

    More information can be found here:

    http://www.astaro.org/astaro-gateway...sl-solved.html

  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: SMTP failed

    Threads merged.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •