Ubuntu 12.04, Rythmbox 2.96, Banshee 2.4.1, 80gb iPod, software version 1.3.

I'm having some issues transferring files to my iPod. In Rythmbox it doesn't work at all, neither syncing or drag/dropping transfers anything to my iPod. Banshee transfers sometimes, sometimes not, same issue. Also, once when I transferred an album over with Banshee, it didn't show up on the iPod. The transfer completed, but nothing showed up after I plugged it out.

Furthermore, after managing to transfer the album with Banshee, one of the files were broken. This was an aubiobook (in mp3, not audiobook format), so needless to say I needed that track. I connected the iPod again, deleted the file, and tried to transfer it again. No go on either Rythmbox or Banshee. I didn't have time to fiddle around with it then, so I switched off the computer. When next I tried to use my iPod, all files were gone. I plugged it in again. Rythmbox said it was completely empty, and wouldn't transfer the album. Banshee said it was half full, but all the files were in the "Other" category, no audio files.

I finally got fed up and booted Win7. iTunes told me I had to restore the iPod, which I did. I then used iTunes to transfer the album.

So my question boils down to this:
Why did my iPod get corrupted? How can I prevent that from happening again? And how can I get transferring working properly again in Ubuntu?