Results 1 to 10 of 15

Thread: xfdesktop and xfce4-panel won't start unless sudo

Threaded View

  1. #1
    Join Date
    Aug 2012
    Beans
    49

    Exclamation xfdesktop and xfce4-panel won't start unless sudo

    On start-up the desktop and panel flash for a moment and then disappear. If I try to run it in a terminal I get this
    xfce4-panel:
    Code:
    Segmentation fault (core dumped)
    josh@josh-Satellite-C655:~$ 
    (wrapper:5702): Gdk-WARNING **: GdkWindow 0x2e00004 unexpectedly destroyed
    The program 'wrapper' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadWindow (invalid Window parameter)'.
      (Details: serial 222 error_code 3 request_code 18 minor_code 0)
      (Note to programmers: normally, X errors are reported asynchronously;
       that is, you will receive the error a while after causing it.
       To debug your program, run it with the --sync command line
       option to change this behavior. You can then get a meaningful
       backtrace from your debugger if you break on the gdk_x_error() function.)
    xfdesktop:
    Code:
    xfdesktop[5762]: starting up
    Segmentation fault (core dumped)
    If I run the --sync option as it says nothing changes and will still display the exact same thing in the terminal. If I run either of these programs under sudo then they work fine so I think this might be an issue of ownership. I just need to know what file i need to take ownership of.
    I'm running Ubuntu 12.04
    Last edited by Champlin93; August 4th, 2012 at 10:31 AM. Reason: Add more detail

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •