Results 1 to 3 of 3

Thread: Ipod Classic suddenly "read only" in rhythmbox and Banshee

  1. #1
    Join Date
    Aug 2012

    Ipod Classic suddenly "read only" in rhythmbox and Banshee

    Apologies if this has been asked lots of times before but I have had a search through old posts and my head is whirling. My computer was set up for me by a friend. It is version unbunto 10:04 > I have been using my ipod classic on Rhythmbox for the last three months then when I was transferring music from my library onto my ipod yesterday the ipod disappeared and wouldn't mount. I took it to the Apple Store and they reset the ipod to factory settings for me. the ipod worked on their macs and itunes. I bought it home and the ipod would now mount but whenever I try to transfer songs from my Rhythmbox library to my ipod I get the message

    Error opening file '/media/Johanna’s iPod/iPod_Control/Music/F08/07. Cuyenda Ndi Jesu.mp3': Read-only file system

    I have no idea how to fix it. Please help me. I now have one song on my ipod that the apple shop put on their to prove it was working and it is AWFUL!
    I am not a IT person so please, if possible, can you explain what to try in idiot speak

    I tried it in Banshee to check it was not an issue with Rhythmbox but that would not put tunes onto my ipod either

  2. #2
    Join Date
    Jun 2009

    Re: Ipod Classic suddenly "read only" in rhythmbox and Banshee

    is the ipod giving any error messages, once my shuffle was blinking to tell the its firmware was damaged, all that happened was the bat got super low, used itunes to fix it

    when a system enters a read-only state it usually means there was a input input error which can be caused by a bad connection or failing media, gparted my be able to check the partition on the ipod and try to repair it if it has been corrupted
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  3. #3
    Join Date
    Aug 2012

    Re: Ipod Classic suddenly "read only" in rhythmbox and Banshee

    Hi, thanks for your reply. There are no error messages and it worked in itunes on the apple shop's macs. It seemed to partially fix it as the ipod would now mount

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts