Results 1 to 2 of 2

Thread: Ethernet and resolution issues on a Toshiba NB510-10R

  1. #1
    Join Date
    Apr 2010

    Ethernet and resolution issues on a Toshiba NB510-10R

    I recently bought a netbook for my wife, on which I wanted to install some GNU/Linux distro (and then get a Windows tax refund as I had already done a couple of years ago).
    It is therefore evident that the installation should have a high WAF (Wife Acceptance Factor), or I would never hear the end of it!

    I chose to install Ubuntu 12.04. The main problems after a fresh install were that the ethernet card (eth0) was not even recognized and that the resolution was stuck at 800x600. These issues were quite easily resolved from already posted solutions. I am just reposting the solutions, distilling them down to the bare essentials for future reference.

    1) Ethernet
    The solution was found here. The problem resides with the Atheros ar8162, for which a driver needs to be manually installed.

    Execute the following:
    tar -xvf compat-wireless-2012-02-28-p.tar 
    cd compat-wireless-2012-02-28-p 
    scripts/driver-select alx 
    sudo make install 
    sudo modprobe alx
    2) Resolution
    The solution was found here.

    a) Add repository and install packages
    sudo add-apt-repository ppa:sarvatt/cedarview 
    sudo apt-get update 
    sudo apt-get install cedarview-drm cedarview-graphics-driver
    b) Restart and at the GRUB prompt, select the Ubuntu entry and press "e".

    c) Using the cursor keys, move to the line containing quiet splash and delete $vt_handoff from it.

    d) Press F10 to boot.

    e) After booting, open /etc/default/grub as root:
    sudo nano /etc/default/grub
    (or use any other text editor)
    Add the following line at the end of the file:

    f) Save changes, close and run
    sudo update-grub
    That's it! Afterwards everything worked fine (including shortcut keys and suspend) and I was a happy husband!
    Last edited by thanasis57; August 3rd, 2012 at 01:43 PM.

  2. #2
    Join Date
    Apr 2013

    Re: Ethernet and resolution issues on a Toshiba NB510-10R

    Hi i have tried your instructions but since i have no internet i have had to download the driver and unzip it that way. problem is i cant use the make command as i am on puppy linux any suggestions

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts