Results 1 to 2 of 2

Thread: How I got my EZCap 646 DVB-T USB TV Tuner up

  1. #1
    Join Date
    Feb 2008
    Land of fire and drought

    Thumbs up How I got my EZCap 646 DVB-T USB TV Tuner up

    * A heads up. I wrote this a long time ago and Taz has given me a heads up in post #2, and I thank them for it. Those instructions install the driver without a problem. My instructions in this post are obsolete and no longer work so disregard. Hopefully this driver will be in the kernel eventually and will work 'out of the box'. Testing 14.04 at the moment and you still need Taz's instructions as the rtl2838 is still not part of the kernel or recognised.

    Good luck to future travellers.

    Disclaimer & Intro:
    I am running an old hybrid of a desktop; Ubuntu Studio with Xubuntu and Ubuntu desktops added to that (among other things). No fresh install since 8.04 LTS (I hit the upgrade button to get to 10.04 LTS about a year ago). Yea, that's right. It’s confusing in there. To add extra spice to the confusion, I’m using kernel version 2.6.38-15-generic, which I think is for 11.04. During the process of getting the EZCap 646 (DVB-T, DAB/DAB+) USB tuner up and running I used the Xfce4 desktop environment.

    Point being I have an unusual setup and a lot of things installed for A/V which you might not have, so if you’re missing software along the way you may need to dig and install some things. This thread is not about that; it is a simple, straight line of the steps that should (theoretically) work to get your EZCap (and probably other devices) working with Me-TV (and definitely other softwares). This is a condensed version of what took me, previously a DVB virgin, about three days of research and experimentation.

    The good news is you don’t need banging specs to get this happening. I’m using a 12 year old box running a Pentium 4, 3Ghz hyperthreading processor with 1Gb of RAM and I can watch TV (HD is fantastic), while surfing the net and having OpenOffice open. All I need to do. Haven’t pushed the envelope as not curious.

    The EZCap could work ‘out-of-the-box’ with newer releases of Ubuntu, in which case, if you’re using something newer than 10.04 LTS, there may be nothing to see here as the driver may be in the kernel. The driver install explanation is for the EZCap but applies to any device with the Realtek rtl2832u chip. The remainder of the post could be applied to any tuner.

    * Update: The driver for this device (and many others) is not in 12.04 LTS as I am using it and needed to install manually.


    First up, if you are getting your signal from an aerial on the roof and need to cover some distance to get to the computer, attempt to use one complete, reliable cable to your computer rather than a few shorter ones cobbled together; more cable joins, less chance of a reliable outcome, time wasted finding the weak link.

    I have the rooftop aerial cable into a two-way aerial splitter (cheap and readily available), one side of the splitter to the PVR/TV setup in the living area, the other using a 10 metre cable to get the signal to the tv tuner in my studio.

    1/ Driver:
    Without the USB tuner in, install the driver using this method (thanks to Joel Stanley.):

    $ sudo apt-get install linux-headers-generic
     $ git clone
     $ cd rtl2832u
     $ make
     $ sudo make modules_install
    Once complete, reboot and once back at a desktop, open a terminal, plug the dongle in, and immediately enter:
    ... then hit ‘return’. You are looking for something similar to this:

    [ 188.114557] DVB: registering new adapter (RTL2832U DVB-T USB DEVICE)
    [ 188.115238] DVB: registering adapter 1 frontend 0 (Realtek RTL2832 DVB-T RTL2836 DTMB)...
    [ 188.115331] dvb-usb: RTL2832U DVB-T USB DEVICE successfully initialized and connected.
    ... near the end of the output. If you don’t see something like that the driver is not installed or installed incorrectly (or Joel’s pulled the link).

    [* There are alternatives. I haven't tried these yet but intend to and will add later, so deviate from the path of this thread at your own risk. Please post back with any results of experimentation with these two options. The first may help getting DAB+ up, which I've had no success with:

    ... and this one I need to spend a bit of time trying to nut out what I'm actually supposed to do. Looks like need to install a modified 3.0.0 kernel:

    * Update: I have successfully installed this driver in 12.04 LTS. Dongle immediately recognised.

    ... back to the story ...]

    2/ Player:
    I tried lots of players (VLC, xine, gxine, Freevo, mplayer, TVTime (but couldn’t work out how to play TV via the dongle with TVTime!)) but settled with Me-TV. If you’re running 10.04 LTS, you can battle away with the old version (as I did) or you can install the Me-TV repository from HERE and save yourself a headache (and also get Me-TV version updates/upgrades when released).

    * Update: I am primarily using Xine now. For my config it seems to run smoother and I prefer the interface. I have no idea how to use it as a PVR; Me-TV is really easy for that.

    The newer version of Me-TV has auto-scan to create a channel list (or whatever it does as there is actually no 'channels.conf' file created that I can find); other players use a channels.conf file placed in their folder (a channels.conf file inside /.xine for instance). In fact, for players that don’t auto-scan (most), a channels.conf appears the only way of getting them to scan for anything (enlighten us if you know more). Here is a link where you have a good chance of finding a scan file to use with dvb-apps scan or w_scan:

    Installing 'x_scan' with the package 'dvb-apps' will scan and create a channels.conf file for your location but that process always refused to register the channels, even though finding them, when I tried it.

    If you want to dig for one, or write one, the syntax for the file name is, say, au-Adelaide, where 'au’=Australia and 'Adelaide’=town. The way I found one was to search for: ‘channels.conf australia’. I found a few. I suggest you try the same tack and good luck with it. (You will find the older version of Me-TV has a 'scan file' which you can work from and you will get stations but there are new channels missing and obsolete when digital takes over shortly in Aus.)

    3/ Launch Me-TV>View>Devices (mine is /dev/dvb/adapter1/frontend0). Now, the output from dmesg when you plugged the dongle in gave important info:

    [  188.115238] DVB: registering adapter 1 frontend 0 (Realtek RTL2832 DVB-T  RTL2836 DTMB)...

    What you find in Me-TV’s ‘Devices’ should match the device info from dmesg when you plugged the dongle in, bolded in the message above .

    If all's going to plan, head to Channels>Add>Auto-scan. Should give an indication of how many channels it’s found (0/35 for instance) and a list of channels for you to add when it finishes. If it doesn’t, there’s something amiss. If so, run Me-TV from a terminal with:

    ... and check the terminal for errors while you are doing a scan. From the error output, start digging for clues.

    If it does pick up a list of channels (give it some time, it can take awhile) wait for it to finish then click ‘Add’ and you should be set.

    For me, the auto-scan worked beautifully and picked up channels I didn’t know we had so hope it's that easy for you.

    Next, tweak about a bit to improve reception or driver and find the right combination for your config. I have an NVidia graphics card (old!) in my machine and have opengl set to best quality in the NVidia config GUI while using the opengl driver in Me-TV and Xine.

    Salient points:

    * If you are using a cable from the aerial at distance, try and use one long, checked cable; no joiners. Save time by knowing what you’re working with from point A;
    * Once you have the aerial into the dongle, plug it in to the computer and check the dmesg for acknowledgement;
    * Once you have the dongle recognised, install a TV Viewer and try to get a station. Before this, you are either going to need to do an auto-scan using Me-TV or a manual scan using another app to create a channels.conf file. To check the dongle is operational and capable of scanning use the Me-TV auto-scan, even if you end up using another app. This will confirm the dongle is operational, up and running;

    * Go for it in stages and don’t let those bleed into each other. First, get the card up. Second, install and tweak the viewer.


    That’s it. Hope this helps to get someone up and running, or at least off the blocks to DVB-dom. Enjoy the ride!

    [Hopefully there will be progress on DAB+ and Linux in the near future. If anyone has any clues about that I'm all ears as I've had no luck.]
    Last edited by Bucky Ball; March 4th, 2014 at 02:34 PM.

  2. #2
    Join Date
    Feb 2013

    Re: How I got my EZCap 646 DVB-T USB TV Tuner up

    Heya! Just thought I'd give you (and others who've come across this thread) a heads up. The drivers for the EZCap are now part of the official LinuxTV Build, which makes our lives a lot easier. All we need to do now is:
    git clone git://
    cd media_build
    sudo make install

    Hope this is helpful. I came across this thread back in the day when I was trying to get this baby working. Hopefully this update can do the same for somebody else.

    Official Site:

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts