Results 1 to 8 of 8

Thread: Non-English Alphabetics in File-Names Display �

  1. #1
    Join Date
    Feb 2011
    Beans
    24

    Non-English Alphabetics in File-Names Display �

    This particularly happens for me in music files, where the names could be French, German or Spanish etc etc so not just one language.

    I have been searching and have read:

    http://cdburnerxp.se/help/appendices/filesystem

    and

    http://www.joelonsoftware.com/articles/Unicode.html

    so I know it is because I need more or a different character set but which one and how do I get it into kubuntu?

    Windows seems to handle this ok but it's a pain to have to export there to fix something and import back.

    Another thing is sometimes I cant do this: kubuntu tells me the file doesn't exist! And I have a pile of files I cannot move or delete because they don't exist...

    I have been searching but none of the threads here or elsewhere seems to match mine.

    What's in a name?

  2. #2
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Non-English Alphabetics in File-Names Display �

    What filesystem is this on?

    Also, can you paste the contents of /etc/mtab?
    ...

  3. #3
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,318
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Non-English Alphabetics in File-Names Display �

    Please also tell us how you get the files onto your system. Ripped from CD? Downloaded from the 'net? Obtained via torrent? Imported from a Windows file system?
    Full Circle Magazine :: Cheap Linux stickers :: Problems with WINE?
    In my day, we had outdoors in which to run, play, and socialise. Now we have computers to do those.

  4. #4
    Join Date
    Feb 2011
    Beans
    24

    Re: Non-English Alphabetics in File-Names Display �

    Thanks for responses.

    Zorael: My drives are ext4.

    I tried '/etc/mtab' with sudo and got '/etc/mtab: command not found'

    Paddy: Usually from Usenet
    or d/l by torrent .


  5. #5
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Non-English Alphabetics in File-Names Display �

    Quote Originally Posted by rich1842 View Post
    Zorael: My drives are ext4.

    I tried '/etc/mtab' with sudo and got '/etc/mtab: command not found'
    Yes, it's just a normal text file and not an executable script. Had it been a FAT or NTFS drive, there would have been a mount option that would force UTF-8 charsets.

    Open up a terminal and enter 'echo $LANG' (no need for sudo). Copy/paste the output here. Does it say UTF-8 after your language code, like lang_LANG.UTF-8?

    To illustrate the effect;
    Code:
    zorael@laughlyn /tmp/test $ echo $LANG
    en_US.UTF-8  # my standard locale is Unicode en_US
    
    zorael@laughlyn /tmp/test $ mkdir '1: 裏庭には二羽庭には二羽鶏がいる'
    zorael@laughlyn /tmp/test $ mkdir '2: @ł𫻩đŋnħ←↓ĸ'
    
    zorael@laughlyn /tmp/test $ LANG=en_US  # dumbing down locale to non-Unicode
    zorael@laughlyn /tmp/test $ ls -1
    1: ?????????????????????????????????????????????
    2: ????????????@???????????????????????????????n??????????
    
    zorael@laughlyn /tmp/test $ LANG=en_US.UTF-8  # restoring
    zorael@laughlyn /tmp/test $ ls -1
    1: 裏庭には二羽庭には二羽鶏がいる
    2: @ł𫻩đŋnħ←↓ĸ
    
    ...

  6. #6
    Join Date
    Feb 2011
    Beans
    24

    SOLVED Re: Non-English Alphabetics in File-Names Display � SOLVED

    This really does work! Lets you delete these files.

    'gksudo nautilus /home/carl/Desktop/' --- example --- takes you to where your file/folder is.

    http://ubuntuforums.org/showthread.php?t=1123479

    That's where I got it.

    ****************************************

    Zorael (thanks for reply) : en_GB.UTF-8

    I am not sure if that was there before: I have been trying different things like

    convmv -r --notest -f windows-1255 -t UTF-8 *

    and

    convmv -r --notest -f windows-1252 -t UTF-8 *

    (1252 is Latin, 1255 is Hebrew)

    and

    sudo apt-get install unifont

    I am hoping these will help avoid problems in future. And the files are gone. I was sure it was to do with character sets.

    When I d/l the files I used pypar2 to verify/repair them and I think it is pypar2 that is the problem.

    I d/l the same set on XP and it's fine - par files did their job etc.

    Just to see, I re-d/l on kubuntu pc and all the files are ok BUT when I opened pypar2 to verify/repair I could see the 'bad' names in pypar2 (and stopped it). So the par files and the data/music files are ok when I get them but the latter are being corrupted by pypar2.

    I can pass the files to XP to verify/repair but it's a pity pypar2 doesn't seem to cope.
    Last edited by rich1842; August 1st, 2012 at 12:31 AM.

  7. #7
    Join Date
    Jul 2007
    Location
    Poland
    Beans
    4,499
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: SOLVED Re: Non-English Alphabetics in File-Names Display � SOLVED

    http://ubuntuforums.org/showthread.php?t=1236012

    convmv should be able to convert windows specific encoding (usually win-125x with x depending on region) to utf8 used by ubuntu.
    if your question is answered, mark the thread as [SOLVED]. Thx.
    To post code or command output, use [code] tags.
    Check your bash script here // BashFAQ // BashPitfalls

  8. #8
    Join Date
    Feb 2011
    Beans
    24

    Re: Non-English Alphabetics in File-Names Display �

    Thanks Vaphell - I have already used convmv to update. I actually think it told me I had not needed to (it brought up a list of files/folders with non-English alphabetics and told me something like 'these are already ok'). As you will see in my previous reply I think now it is pypar2 that is the culprit.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •