Results 1 to 3 of 3

Thread: Unity broken after wine install/remove

  1. #1
    Join Date
    Oct 2012

    Unity broken after wine install/remove

    Hello Everybody!

    Yesterday I installed the nvidia driver for my laptop. What actually worked in the end.

    Linux: Ubuntu 12.04
    Graphic card: GeForce GT 330M

    But today, after restart (computer was switched off while I was sleeping ) it does not use the nvidia driver anymore.


    1. I cannot set icon size of launcher anymor
    2. openGL does not work anymore
    3. all cool window effects (shadows, transition) do not work anymore

    all in all when I was searching I could find out that it is connected to the unity mode 2d and 3d, while it refuses to use 3d.

    that is the result of running the **unity_test -p**

    Yesterday it worked, today not --> it is not depending on the hardware, something broke when deinstalling wine1.5, with this I am quiet sure but I do not know how to fix it.



    so I tried to reinstall xorg with:

    apt-get remove --purge xserver-xorg
    apt-get install xserver-xorg

    nothing changed

    and when I tried just to reinstall the graphics driver with

    apt-get remove --purge nvidia*

    it tells me that nothing was removed...

    what could I try???
    Last edited by schmi85; October 7th, 2012 at 01:32 PM.

  2. #2
    Join Date
    Jul 2011
    Ubuntu 12.04 Precise Pangolin

    Re: Unity broken after wine install/remove

    If you can't remove the nVidia driver, it may have been remove before and this could also be the reason why you are in Unity2D instead of Unity3D. Did you try to install the nVidia driver again?

  3. #3
    Join Date
    Oct 2012

    Re: Unity broken after wine install/remove


    The driver was installed. But re installing it solved the problem. Now everything works fine again.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts