Results 1 to 7 of 7

Thread: Screen Brightness - No Steps

  1. #1
    Join Date
    Nov 2007
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Exclamation Screen Brightness - No Steps

    When I use my keyboard to change brightness on my laptop it just jumps straight from minimum to maximum (or maximum to minimum if decreasing) without stopping.

    If I use the slider for brightness in Ubuntu (under settings), I can drag it, but when I let go it just slides straight to the maximum or minimum.

    The only way to control brightness at a level in between maximum and minimum is to "echo x > /sys/class/backlight/acpi_video0/brightness". x = a value from 0-7.

    Any ideas as to what's wrong?

    edit: Using Ubuntu 12.04, 3.2 kernel.

    edit 2: It was annoying so I formatted and reinstalled. This fixed the problem... until I updated. One of the updates is causing this but I don't know which one (there were well over 300 after a new install).
    Last edited by roton; July 24th, 2012 at 05:21 AM. Reason: added OS info

  2. #2
    Join Date
    Nov 2007
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Screen Brightness - No Steps

    Ok it seems to be the new kernel (3.2.0-27) causing the issue. But since it's an "important update" should I put up with the inconvenient brightness controls?
    Is it even safe to stay on the older 3.2.0-23?

  3. #3
    Join Date
    Feb 2012
    Location
    Athens/Greece
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Screen Brightness - No Steps

    Hi ,
    did you try to add a parameter in grub ?
    open
    Code:
    gksudo gedit /etc/default/grub
    find the line
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    and make it
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

    save the document and go to terminal again and
    Code:
    sudo update-grub
    Reboot your pc for changes take effects

    If works ok ,
    if not , then i assume you understand how you can undo the above change.

    Thanks

  4. #4
    Join Date
    Nov 2007
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Screen Brightness - No Steps

    Thanks NikTh, that sort of worked. I can now adjust the brightness using the slider under settings. However, using the keys now bumps it up to max and decreases to only 1 setting below max, it refuses to go lower no matter now much you press the key.
    Last edited by roton; July 24th, 2012 at 01:56 PM.

  5. #5
    Join Date
    Feb 2012
    Location
    Athens/Greece
    Beans
    Hidden!
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: Screen Brightness - No Steps

    Quote Originally Posted by roton View Post
    Thanks NikTh, that sort of worked. I can now adjust the brightness using the slider under settings. However, using the keys now bumps it up to max and decreases to only 1 setting below max, it refuses to go lower no matter now much you press the key.
    Hi ,
    ok maybe you want to test with one parameter.. e.g , only acpi_osi=Linux or acpi_backlight=vendor .
    You know the way how to modify the file.. so you can test one parameter at time.

    do not forger to update-grub

    Thanks

  6. #6
    Join Date
    Nov 2007
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Screen Brightness - No Steps

    It finally works now using:

    GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi="

    Thanks for all your help. Have marked as solved.

    edit: Yay my 50th post... finally I can modify my profile
    Last edited by roton; July 24th, 2012 at 02:44 PM.

  7. #7
    Join Date
    May 2012
    Beans
    2

    Re: Screen Brightness - No Steps

    Quote Originally Posted by roton View Post
    It finally works now using:

    GRUB_CMDLINE_LINUX_DEFAULT="quite splash acpi_osi="
    this works for me too. Must have been the kernel update. Thanks for the fix!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •