Results 1 to 2 of 2

Thread: glc-play won't play - "invalid argument" error

  1. #1
    Join Date
    Apr 2012
    Beans
    9

    glc-play won't play - "invalid argument" error

    I'm running Ubuntu 12.04.

    I want to capture some video from a game. From what I found, glc is the way to go, and all the instructions and tutorials I've read are pretty much the same. Real simple.

    So, I installed the latest version, and tried it on Nexuiz to keep things simple.

    glc-capture /usr/games/nexuiz

    I ran that command, started the game, hit SHIFT+F8, played for a minute or two, hit SHIFT+F8, and exited the game. Got a file called "darkplaces-21827-0.glc" that looks to be over 800MB in size! I just want to see if the video works, so I typed in:

    glc-play darkplaces-21827-0.glc

    This is the entirety of the output I got:

    [ 0.49s glc_thread error ] Invalid argument (22)
    [ 0.49s rgb error ] Invalid argument (22)
    [ 0.49s glc_thread error ] Invalid argument (22)
    [ 0.49s glc_thread error ] Invalid argument (22)
    [ 0.49s scale error ] Invalid argument (22)
    [ 0.50s color error ] Invalid argument (22)

    I tried this same procedure with a windows game run through PlayOnLinux, and got the exact same results - large glc file and error in glc-play. I also tried using PlayOnLinux's "Capture" plugin (which uses glc), and got absolutely no response from that whatsoever - i.e. no capture file that I could find.

    I can't seem to get this simple process to work! Any ideas? Suggestions? Help??

  2. #2
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,375
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: glc-play won't play - "invalid argument" error

    I have not tried glc; I do not find it in the repositories.

    I have found Record My Desktop to work well. I suggest you try it. You may need to experiment with the performance settings, depending on your hardware.

    You could also try Istanbul Desktop Session Recorder, but I have not tested it.
    Full system encryption with dual-boot —— Full Circle Magazine —— Problems with WINE?
    In my day, we had the outdoors in which to run, play, and socialise. Now people use computers for that.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •