Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 12.04 keeps nagging me to upgrade

  1. #1
    Join Date
    Sep 2007
    Location
    over there
    Beans
    2,518
    Distro
    Ubuntu 12.04 Precise Pangolin

    12.04 keeps nagging me to upgrade

    12.04 64-bit on my laptop, keeps telling me to upgrade, telling me to close my apps and press OK to upgrade. But I don't want to upgrade. How do I get it to stop?

    When I run Update Manager I keep getting this message. In Settings, I've got Update Manager to tell me about new LTS releases, and I certainly haven't asked to upgrade...

    Attached Images Attached Images
    Last edited by t0p; September 14th, 2012 at 04:24 PM.
    "All people are scum. No matter what they look like." ~ Spider Jerusalem, Transmetropolitan #4
    blog photoblog


  2. #2
    Join Date
    Feb 2008
    Location
    Oblivion
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 12.04 keeps nagging me to upgrade

    You can open Update Manager then click Settings in the bottom left corner.

    Click the Updates tab and set 'Notify me of new Ubuntu version' to 'Never'.

  3. #3
    Join Date
    Jun 2011
    Location
    Netherlands
    Beans
    146
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: 12.04 keeps nagging me to upgrade

    Open Software Sources by typing in the terminal:
    Code:
    software-properties-gtk
    Click on the Updates tab.
    I think you'll figure out what to configure there yourself.

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 12.04 keeps nagging me to upgrade

    It's not offering you any upgrade to a new Ubuntu release or anyhting like that, but just a normal (and rather important!) security update.

  5. #5
    Join Date
    Sep 2007
    Location
    over there
    Beans
    2,518
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 keeps nagging me to upgrade

    Quote Originally Posted by mcduck View Post
    It's not offering you any upgrade to a new Ubuntu release or anyhting like that, but just a normal (and rather important!) security update.
    That's what I thought at first, but when I started to go through with it, it wasn't like any normal update (can't recall messages exactly, but there was stuff like "close all applications" and others, stuff that I've never seen from Update Manager before - and I've been using Ubuntu since 2007). Plus the fact that it says "upgrade" and "partial upgrade". And at one point it does say "distribution upgrade".

    I'm going to see what happens with the other suggestions. In the meantime, any other thoughts anybody?
    "All people are scum. No matter what they look like." ~ Spider Jerusalem, Transmetropolitan #4
    blog photoblog


  6. #6
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 12.04 keeps nagging me to upgrade

    Quote Originally Posted by t0p View Post
    That's what I thought at first, but when I started to go through with it, it wasn't like any normal update (can't recall messages exactly, but there was stuff like "close all applications" and others, stuff that I've never seen from Update Manager before - and I've been using Ubuntu since 2007). Plus the fact that it says "upgrade" and "partial upgrade". And at one point it does say "distribution upgrade".

    I'm going to see what happens with the other suggestions. In the meantime, any other thoughts anybody?
    the "upgrade" term is just used in the same context as with apt-get, which uses "update" when meaning that it's refreshing the information about available packages, while "upgrade" and "dist-upgrade" refer to actually downloading and installing the new package versions.

    ...and "partial upgrade" simply means that the package manager has information about new versions of some packages, but for some reason or other some of them aren't actually available or can't be installed at the moment. Usually that happens when the update manager checks for updates while new packages are still being added to the repository server, in which case simply waiting a while and refreshing the package information solves the problem.

    At least in your screenshot there's nothing that would point to a release upgrade.

    edit: Of course if you want to be sure, you can always open a terminal and run "sudo apt-get update && sudo apt-get upgrade" and post the output here.

  7. #7
    Join Date
    Sep 2007
    Location
    over there
    Beans
    2,518
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 keeps nagging me to upgrade

    Of course if you want to be sure, you can always open a terminal and run "sudo apt-get update && sudo apt-get upgrade" and post the output here.
    Code:
    t0p@mars:~$ sudo apt-get update && sudo apt-get upgrade
    [sudo] password for t0p: 
    Ign http://security.ubuntu.com precise-security InRelease                
    Ign http://dl.google.com stable InRelease                                
    Ign http://gb.archive.ubuntu.com precise InRelease                       
    Ign http://linux.dropbox.com precise InRelease                           
    Get:1 http://security.ubuntu.com precise-security Release.gpg [198 B]    
    Get:2 http://security.ubuntu.com precise-security Release [49.6 kB]      
    Ign http://gb.archive.ubuntu.com precise-updates InRelease               
    Ign http://gb.archive.ubuntu.com precise-backports InRelease             
    Hit http://dl.google.com stable Release.gpg                              
    Hit http://gb.archive.ubuntu.com precise Release.gpg                     
    Hit http://dl.google.com stable Release                                  
    Get:3 http://gb.archive.ubuntu.com precise-updates Release.gpg [198 B]   
    Hit http://dl.google.com stable/main amd64 Packages                      
    Hit http://gb.archive.ubuntu.com precise-backports Release.gpg           
    Hit http://dl.google.com stable/main i386 Packages                       
    Ign http://dl.google.com stable/main TranslationIndex                    
    Get:4 http://security.ubuntu.com precise-security/main Sources [42.8 kB] 
    Hit http://gb.archive.ubuntu.com precise Release                         
    Get:5 http://gb.archive.ubuntu.com precise-updates Release [49.6 kB]     
    Get:6 http://security.ubuntu.com precise-security/restricted Sources [1,950 B]
    Get:7 http://security.ubuntu.com precise-security/universe Sources [13.5 kB]
    Get:8 http://security.ubuntu.com precise-security/multiverse Sources [1,386 B]
    Get:9 http://security.ubuntu.com precise-security/main amd64 Packages [161 kB]
    Hit http://gb.archive.ubuntu.com precise-backports Release               
    Get:10 http://security.ubuntu.com precise-security/restricted amd64 Packages [3,969 B]
    Get:11 http://security.ubuntu.com precise-security/universe amd64 Packages [43.8 kB]
    Ign http://ppa.launchpad.net precise InRelease                           
    Ign http://extras.ubuntu.com precise InRelease                           
    Hit http://gb.archive.ubuntu.com precise/main Sources                    
    Hit http://gb.archive.ubuntu.com precise/restricted Sources              
    Hit http://gb.archive.ubuntu.com precise/universe Sources                
    Hit http://gb.archive.ubuntu.com precise/multiverse Sources              
    Hit http://gb.archive.ubuntu.com precise/main amd64 Packages             
    Hit http://gb.archive.ubuntu.com precise/restricted amd64 Packages       
    Hit http://gb.archive.ubuntu.com precise/universe amd64 Packages         
    Hit http://gb.archive.ubuntu.com precise/multiverse amd64 Packages       
    Get:12 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2,180 B]
    Get:13 http://security.ubuntu.com precise-security/main i386 Packages [165 kB]
    Hit http://linux.dropbox.com precise Release.gpg                         
    Hit http://ppa.launchpad.net precise Release.gpg                         
    Get:14 http://extras.ubuntu.com precise Release.gpg [72 B]               
    Hit http://gb.archive.ubuntu.com precise/main i386 Packages              
    Hit http://gb.archive.ubuntu.com precise/restricted i386 Packages        
    Hit http://gb.archive.ubuntu.com precise/universe i386 Packages          
    Hit http://gb.archive.ubuntu.com precise/multiverse i386 Packages        
    Hit http://gb.archive.ubuntu.com precise/main TranslationIndex           
    Hit http://gb.archive.ubuntu.com precise/multiverse TranslationIndex     
    Hit http://gb.archive.ubuntu.com precise/restricted TranslationIndex     
    Get:15 http://security.ubuntu.com precise-security/restricted i386 Packages [3,968 B]
    Get:16 http://security.ubuntu.com precise-security/universe i386 Packages [43.9 kB]
    Get:17 http://security.ubuntu.com precise-security/multiverse i386 Packages [2,369 B]
    Hit http://security.ubuntu.com precise-security/main TranslationIndex    
    Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
    Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
    Hit http://security.ubuntu.com precise-security/universe TranslationIndex
    Hit http://ppa.launchpad.net precise Release                             
    Hit http://extras.ubuntu.com precise Release                             
    Hit http://gb.archive.ubuntu.com precise/universe TranslationIndex       
    Get:18 http://gb.archive.ubuntu.com precise-updates/main Sources [164 kB]
    Hit http://linux.dropbox.com precise Release                             
    Hit http://security.ubuntu.com precise-security/main Translation-en      
    Hit http://security.ubuntu.com precise-security/multiverse Translation-en
    Hit http://ppa.launchpad.net precise/main Sources                        
    Hit http://extras.ubuntu.com precise/main Sources                        
    Hit http://security.ubuntu.com precise-security/restricted Translation-en
    Hit http://ppa.launchpad.net precise/main amd64 Packages                 
    Hit http://ppa.launchpad.net precise/main i386 Packages                  
    Ign http://ppa.launchpad.net precise/main TranslationIndex               
    Hit http://linux.dropbox.com precise/main amd64 Packages                 
    Hit http://extras.ubuntu.com precise/main amd64 Packages                 
    Hit http://extras.ubuntu.com precise/main i386 Packages                  
    Ign http://extras.ubuntu.com precise/main TranslationIndex               
    Ign http://dl.google.com stable/main Translation-en_GB                   
    Hit http://security.ubuntu.com precise-security/universe Translation-en  
    Hit http://linux.dropbox.com precise/main i386 Packages                  
    Ign http://dl.google.com stable/main Translation-en                      
    Ign http://linux.dropbox.com precise/main TranslationIndex               
    Ign http://ppa.launchpad.net precise/main Translation-en_GB              
    Get:19 http://gb.archive.ubuntu.com precise-updates/restricted Sources [3,285 B]
    Get:20 http://gb.archive.ubuntu.com precise-updates/universe Sources [51.8 kB]
    Ign http://ppa.launchpad.net precise/main Translation-en                 
    Ign http://extras.ubuntu.com precise/main Translation-en_GB              
    Ign http://extras.ubuntu.com precise/main Translation-en                 
    Get:21 http://gb.archive.ubuntu.com precise-updates/multiverse Sources [4,241 B]
    Get:22 http://gb.archive.ubuntu.com precise-updates/main amd64 Packages [383 kB]
    Ign http://linux.dropbox.com precise/main Translation-en_GB              
    Ign http://linux.dropbox.com precise/main Translation-en                 
    Get:23 http://gb.archive.ubuntu.com precise-updates/restricted amd64 Packages [6,755 B]
    Get:24 http://gb.archive.ubuntu.com precise-updates/universe amd64 Packages [130 kB]
    Get:25 http://gb.archive.ubuntu.com precise-updates/multiverse amd64 Packages [8,677 B]
    Get:26 http://gb.archive.ubuntu.com precise-updates/main i386 Packages [388 kB]
    Get:27 http://gb.archive.ubuntu.com precise-updates/restricted i386 Packages [6,732 B]
    Get:28 http://gb.archive.ubuntu.com precise-updates/universe i386 Packages [131 kB]
    Get:29 http://gb.archive.ubuntu.com precise-updates/multiverse i386 Packages [9,672 B]
    Hit http://gb.archive.ubuntu.com precise-updates/main TranslationIndex   
    Hit http://gb.archive.ubuntu.com precise-updates/multiverse TranslationIndex
    Hit http://gb.archive.ubuntu.com precise-updates/restricted TranslationIndex
    Hit http://gb.archive.ubuntu.com precise-updates/universe TranslationIndex
    Hit http://gb.archive.ubuntu.com precise-backports/main Sources          
    Hit http://gb.archive.ubuntu.com precise-backports/restricted Sources    
    Hit http://gb.archive.ubuntu.com precise-backports/universe Sources      
    Hit http://gb.archive.ubuntu.com precise-backports/multiverse Sources    
    Hit http://gb.archive.ubuntu.com precise-backports/main amd64 Packages   
    Hit http://gb.archive.ubuntu.com precise-backports/restricted amd64 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/universe amd64 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/multiverse amd64 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/main i386 Packages    
    Hit http://gb.archive.ubuntu.com precise-backports/restricted i386 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/universe i386 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/multiverse i386 Packages
    Hit http://gb.archive.ubuntu.com precise-backports/main TranslationIndex 
    Hit http://gb.archive.ubuntu.com precise-backports/multiverse TranslationIndex
    Hit http://gb.archive.ubuntu.com precise-backports/restricted TranslationIndex
    Hit http://gb.archive.ubuntu.com precise-backports/universe TranslationIndex
    Hit http://gb.archive.ubuntu.com precise/main Translation-en_GB          
    Hit http://gb.archive.ubuntu.com precise/main Translation-en             
    Hit http://gb.archive.ubuntu.com precise/multiverse Translation-en_GB    
    Hit http://gb.archive.ubuntu.com precise/multiverse Translation-en       
    Hit http://gb.archive.ubuntu.com precise/restricted Translation-en_GB    
    Hit http://gb.archive.ubuntu.com precise/restricted Translation-en       
    Hit http://gb.archive.ubuntu.com precise/universe Translation-en_GB      
    Hit http://gb.archive.ubuntu.com precise/universe Translation-en         
    Hit http://gb.archive.ubuntu.com precise-updates/main Translation-en_GB  
    Hit http://gb.archive.ubuntu.com precise-updates/main Translation-en     
    Hit http://gb.archive.ubuntu.com precise-updates/multiverse Translation-en_GB
    Hit http://gb.archive.ubuntu.com precise-updates/multiverse Translation-en
    Hit http://gb.archive.ubuntu.com precise-updates/restricted Translation-en_GB
    Hit http://gb.archive.ubuntu.com precise-updates/restricted Translation-en
    Hit http://gb.archive.ubuntu.com precise-updates/universe Translation-en_GB
    Hit http://gb.archive.ubuntu.com precise-updates/universe Translation-en 
    Hit http://gb.archive.ubuntu.com precise-backports/main Translation-en   
    Hit http://gb.archive.ubuntu.com precise-backports/multiverse Translation-en
    Hit http://gb.archive.ubuntu.com precise-backports/restricted Translation-en
    Hit http://gb.archive.ubuntu.com precise-backports/universe Translation-en
    Fetched 1,872 kB in 1min 23s (22.4 kB/s)                                 
    Reading package lists... Done
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages have been kept back:
      ginn icedtea-7-jre-jamvm libgrip0 openjdk-7-jre openjdk-7-jre-headless
    0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
    So what are you suggesting, that I should go through with what update manager wants?
    "All people are scum. No matter what they look like." ~ Spider Jerusalem, Transmetropolitan #4
    blog photoblog


  8. #8
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 12.04 keeps nagging me to upgrade

    Based on that output, it really is just soem normal updates. I actually had the same issue with only aprtial update being possible, and it was because the Java updates required adding a couple of new packages and removing one existing one, which the Upadate Manager isn't allowed to do.

    So yes, you should install the updates, but instead of doing the partial upgrade with the Update Managager you should either use Synaptic Package Manager, or run "sudo apt-get dist-upgrade" in a terminal.

  9. #9
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,426
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: 12.04 keeps nagging me to upgrade

    The wording is misleading. It is not a partial upgrade, but what is known as a "distribution upgrade" (although that wording, too, is misleading).

    Go ahead with the "partial upgrade". It is absolutely fine.
    Full system encryption with dual-boot (beta) —— Full Circle Magazine —— Problems with WINE?
    In my day, we had the outdoors in which to run, play, and socialise. Now people use computers for that.

  10. #10
    Join Date
    Aug 2008
    Location
    Jawja
    Beans
    2,486
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: 12.04 keeps nagging me to upgrade

    Quote Originally Posted by t0p View Post
    12.04 64-bit on my laptop, keeps telling me to upgrade, telling me to close my apps and press OK to upgrade. But I don't want to upgrade. How do I get it to stop?

    When I run Update Manager I keep getting this message. In Settings, I've got Update Manager to tell me about new LTS releases, and I certainly haven't asked to upgrade...

    I keep getting the same message but I have removed the Unity packages. I notice the partial upgrade wants to reinstall those packages. Did you remove any Unity packages prior to this? See this: http://ubuntuforums.org/showthread.php?t=2057040

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •