Results 1 to 7 of 7

Thread: [Ubuntu 12.04] After Reboot, Broadcom STA Driver not working.

Threaded View

  1. #1
    Join Date
    Jul 2012

    Arrow [Ubuntu 12.04] After Reboot, Broadcom STA Driver not working.

    Gone through many forums but nothing seems to have worked in my case.

    I have Ubuntu 12.04 installed on my Dell Inspiron 1464 Laptop with Wubi. The other operating system being Windows 7.

    The wireless on Windows is working perfectly fine but not on Ubuntu. Initially, in Ubuntu 12.04 the wireless used to work perfectly fine but not lately. (Note. I keep on updating my Ubuntu regularly. So, might be the case.)

    The Exact Problem is:

    Everytime I restart my laptop, the Additional Driver for "Broadcom STA wireless driver" says "This driver is activated but not currently in use". So, in order to make it work, I have to remove and re-activate the driver to make it work every time I boot.

    I have blacklisted bcma and brcm80211 as mentioned in this
    thread... I have followed all the steps as mentioned in the thread but it hasn't worked in my case.

    The Outputs of few Commands which may help the "Super Geeks" solve my problem.

    lspci -vvnn | grep 14e4
    03:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    sudo lshw -C network
      *-network UNCLAIMED     
           description: Network controller
           product: BCM4312 802.11b/g LP-PHY
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:03:00.0
           version: 01
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: latency=0
           resources: memory:f0400000-f0403fff
           description: Ethernet interface
           product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:04:00.0
           logical name: eth0
           version: 02
           serial: b8:ac:6f:6c:e3:62
           size: 100Mbit/s
           capacity: 100Mbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
           resources: irq:41 ioport:2000(size=256) memory:f0810000-f0810fff memory:f0800000-f080ffff memory:f0820000-f083ffff
    Presently, these are the packages installed in my laptop
    Guys, I am really frustrated cause of this, I have been trying occasionally, looking over the forums on internet and trying to fix it by myself.

    Thanks in advance.

    Last edited by matt_symes; July 20th, 2012 at 05:14 PM. Reason: It's only a PC

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts