Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Having issues setting up DNS

  1. #11
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    2,854
    Distro
    Ubuntu Development Release

    Re: Having issues setting up DNS

    It would help us if you would post your bind config files.
    Myself, I have no clue what is wrong from the description.
    I also recommend using the ubuntu server guide (pdf). I have found the DNS chapter to be pretty good. It was the only reference I used to setup my internal DNS.

  2. #12
    Join Date
    Jul 2007
    Location
    East Anglia, UK
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Having issues setting up DNS

    This is named.conf.local:
    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    zone "fluid.dev" {
    	type master;
            file "/etc/bind/db.fluid.dev";
    };
    zone "pathways-plus.dev" {
    	type master;
    	file "/etc/bind/db.pathways-plus.dev";
    };
    zone "254.168.192.in-addr.arpa" {
            type master;
            file "/etc/bind/rev.db.192";
    };
    db.fluid.dev:
    Code:
    ; BIND data file for fluid.dev
    ; 
    $ORIGIN fluid.dev.
    $TTL 	604800
    @ 	IN 	SOA 	ns1.fluid.dev. admin.fluid.dev. (
    				2012072404 ; Serial
    				28800 ; Refresh 
    				3600 ; Retry 
    				604800 ; Expire 
    				38400 ) ; Negative Cache TTL 
    ;  
    
    		IN	NS	ns1.fluid.dev.
    		IN	MX 10	mail.fluid.dev.
    
    localhost	IN	A	127.0.0.1
    fluid.dev. 	IN	A	192.168.254.60
    ns1		IN	A	192.168.254.60
    
    www		IN	A	192.168.254.60
    ftp		IN	A	192.168.254.60
    mail		IN	A	192.168.254.60
    db.pathways-plus.dev:
    Code:
    ; BIND data file for pathways-plus.dev.
    ; 
    $ORIGIN pathways-plus.dev.
    $TTL 	604800
    @ 	IN 	SOA 	ns1.pathways-plus.dev. admin.pathways-plus.dev. (
    				2012072402 ; Serial
    				28800 ; Refresh 
    				3600 ; Retry 
    				604800 ; Expire 
    				38400 ) ; Negative Cache TTL 
    ;  
    
    			IN	NS	ns1.pathways-plus.dev.
    			IN	MX 10	mail.pathways-plus.dev.
    
    localhost		IN	A	127.0.0.1
    pathways-plus.dev.	IN	A	192.168.254.60
    ns1			IN	A	192.168.254.60
    
    www			IN	A	192.168.254.60
    ftp			IN	A	192.168.254.60
    mail			IN	A	192.168.254.60
    rev.db.192:
    Code:
    ;
    ; BIND reverse data file for local 192.168.254.XXX net
    ;
    $TTL    604800
    @       IN      SOA     ns1.fluid.dev. admin.fluid.dev. (
                         2012072402         ; Serial
                             604800         ; Refresh
                              86400         ; Retry
                            2419200         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
    @       IN      NS      ns1.
    60      IN      PTR     ns1.fluid.dev.
    fluid.dev points to the main apache folder and I consider it the "main" website. Pathways-plus.dev is the first website I have set up as an extra virtual host to work on.

  3. #13
    Join Date
    Feb 2011
    Location
    Coquitlam, B.C. Canada
    Beans
    2,854
    Distro
    Ubuntu Development Release

    Re: Having issues setting up DNS

    For db.fliud.dev, try this (I don't know why it is not formatting properly, tabs seems to have changed to spaces):
    Code:
    ; BIND data file for fluid.dev
    ; 
    $TTL  604800
    @  IN  SOA  fluid.dev. admin.fluid.dev. (
        2012072404 ; Serial
        28800 ; Refresh 
        3600 ; Retry 
        604800 ; Expire 
        38400 ) ; Negative Cache TTL 
    ;  
    @  IN NS ns1.fluid.dev.
      IN MX 10 mail.fluid.dev.
    ns1  IN A 192.168.254.60
    www  IN A 192.168.254.60
    ftp  IN A 192.168.254.60
    mail  IN A 192.168.254.60
    Similarly for the other one, if this helps.

  4. #14
    Join Date
    Mar 2007
    Location
    ho chi minh city
    Beans
    225
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Having issues setting up DNS

    Quote Originally Posted by styphon View Post
    This is named.conf.local:
    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    zone "fluid.dev" {
    	type master;
            file "/etc/bind/db.fluid.dev";
    };
    zone "pathways-plus.dev" {
    	type master;
    	file "/etc/bind/db.pathways-plus.dev";
    };
    zone "254.168.192.in-addr.arpa" {
            type master;
            file "/etc/bind/rev.db.192";
    };
    db.fluid.dev:
    Code:
    ; BIND data file for fluid.dev
    ; 
    $ORIGIN fluid.dev.
    $TTL 	604800
    @ 	IN 	SOA 	ns1.fluid.dev. admin.fluid.dev. (
    				2012072404 ; Serial
    				28800 ; Refresh 
    				3600 ; Retry 
    				604800 ; Expire 
    				38400 ) ; Negative Cache TTL 
    ;  
    
    		IN	NS	ns1.fluid.dev.
    		IN	MX 10	mail.fluid.dev.
    
    localhost	IN	A	127.0.0.1
    fluid.dev. 	IN	A	192.168.254.60
    ns1		IN	A	192.168.254.60
    
    www		IN	A	192.168.254.60
    ftp		IN	A	192.168.254.60
    mail		IN	A	192.168.254.60
    db.pathways-plus.dev:
    Code:
    ; BIND data file for pathways-plus.dev.
    ; 
    $ORIGIN pathways-plus.dev.
    $TTL 	604800
    @ 	IN 	SOA 	ns1.pathways-plus.dev. admin.pathways-plus.dev. (
    				2012072402 ; Serial
    				28800 ; Refresh 
    				3600 ; Retry 
    				604800 ; Expire 
    				38400 ) ; Negative Cache TTL 
    ;  
    
    			IN	NS	ns1.pathways-plus.dev.
    			IN	MX 10	mail.pathways-plus.dev.
    
    localhost		IN	A	127.0.0.1
    pathways-plus.dev.	IN	A	192.168.254.60
    ns1			IN	A	192.168.254.60
    
    www			IN	A	192.168.254.60
    ftp			IN	A	192.168.254.60
    mail			IN	A	192.168.254.60
    rev.db.192:
    Code:
    ;
    ; BIND reverse data file for local 192.168.254.XXX net
    ;
    $TTL    604800
    @       IN      SOA     ns1.fluid.dev. admin.fluid.dev. (
                         2012072402         ; Serial
                             604800         ; Refresh
                              86400         ; Retry
                            2419200         ; Expire
                             604800 )       ; Negative Cache TTL
    ;
    @       IN      NS      ns1.
    60      IN      PTR     ns1.fluid.dev.
    fluid.dev points to the main apache folder and I consider it the "main" website. Pathways-plus.dev is the first website I have set up as an extra virtual host to work on.
    Both ns1.fluid.dev and ns1.pathways-plus.dev use ONE IP address. What are you trying to achieve? Redundancy? If you want redundancy, set up another dns server and add an entry in ns1.fluid.dev to point to it.
    Leave out the localhost. It's already handled when you install bind9. That's the way it is with ubuntu.

    In your rev.db.192. It should be
    @ IN NS ns1.fluid.dev.

    Tackle one target at a time. Leave out the pathways-plus zone and make sure that your fluid.dev zone is running fine before you add more zones.

    Please run the following commands on your DNS server machine and paste the results here:
    cat /etc/hosts and /etc/resolv.conf
    Nvidia 525M and bumblebee 3.x

  5. #15
    Join Date
    Jul 2007
    Location
    East Anglia, UK
    Beans
    76
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Having issues setting up DNS

    Thanks guys for the help.

    tenmoi, I've got both pointing to the same IP because it's a LAMP server with virtual hosts, this is our in-house development server. Eventually I will have hundreds of sites each with a DNS record, all pointing to this server.

    I have commented out the pathways-plus zone from named.conf.local for now until we can get fluid.dev working. I changed the record to look as above, both for the forward and reverse lookup files.

    If I browse to fluid.dev on the ubuntu server it works perfectly fine. However still no joy on the windows machine.

    nslookup from Win7 machine:
    Code:
    C:\Users\Fluid>nslookup fluid.dev
    Server:  ns1.fluid.dev
    Address:  192.168.254.60
    
    Name:    fluid.dev
    ping fluid.dev comes up with could not find host, however ns1.fluid.dev comes up with the correct IP now. I had to change my secondary DNS from OpenDNS to my router to get this though (seems OpenDNS was interfering).

    Browsing to ns1.fluid.dev now works, as does www.fluid.dev but still not fluid.dev on it's own, what's missing? I tried adding a * A record but that didn't work.

    EDIT: I'm being slow this morning. For some reason I forgot how to add a blank A record. I've got it working now, and the pathways-plus.dev domain. Thank you all for your help on this .
    Last edited by styphon; July 25th, 2012 at 10:28 AM.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •