Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: disable auto mic gain?

  1. #1
    Join Date
    Jul 2008
    Beans
    19

    disable auto mic gain?

    I'm trying to use a Logitech H530 usb headset on my Thinkpad Edge13 running ubuntu 12.04 64 bit, and the automatic mic gain keeps pushing the mic volume to 100% [so, the volume is WAY too loud and picks up lots of background noise etc], even as I've turned it down in alsamixer and pulseaudio. I've searched, but been unable to find anything about how to disable the auto mic gain or otherwise fix this problem.
    sound card is:
    andre@andre-ThinkPad-Edge:~$ lspci | grep -i audio
    00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

    Any advice would be appreciated.
    Thanks.

  2. #2
    Join Date
    Jul 2008
    Beans
    19

    Re: disable auto mic gain?

    bump

  3. #3
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable auto mic gain?

    Welcome to Ubuntu

    Try installing pulse audio volume control:
    Code:
     sudo apt-get install pavucontrol
    And to open
    Code:
     pavucontrol
    This should give you an option for your mic.

  4. #4
    Join Date
    Jul 2008
    Beans
    19

    Re: disable auto mic gain?

    Quote Originally Posted by jmfal View Post
    Welcome to Ubuntu

    Try installing pulse audio volume control:
    Code:
     sudo apt-get install pavucontrol
    And to open
    Code:
     pavucontrol
    This should give you an option for your mic.
    Thanks for your reply. What I meant by having tried to adjust the mic gain in 'pulseaudio' in my original post is just what you've suggested - pulse audio control. It does indeed give me an option to regulate the mic level, but after I've done that, it automatically pushes the level back up to 100% [not immediately, but over about 20-30 seconds]. That is why I'm looking for some way to disable the auto mic gain feature.
    Any advice on doing that would be greatly appeciated

  5. #5
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable auto mic gain?

    Open alsamixer
    press F5
    look for mic boost
    and turn off (press m or M)
    Leave alsamixer open
    check if problem solved
    if so
    Press esc key
    at command prompt enter
    Code:
     sudo alsactl store
    This will save alsamixer settings

  6. #6
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

  7. #7
    Join Date
    Jul 2008
    Beans
    19

    Re: disable auto mic gain?

    Quote Originally Posted by jmfal View Post
    Open alsamixer
    press F5
    look for mic boost
    and turn off (press m or M)
    Leave alsamixer open
    check if problem solved
    if so
    Press esc key
    at command prompt enter
    Code:
     sudo alsactl store
    This will save alsamixer settings
    thanks for your continued effort to help me solve this.
    Although I feel that I've seen a 'mic boost' option in alsamixer before, there is not one there now. The tabs in alsamixer are:
    Master
    <Headphone>
    Speaker
    PCM
    S/PDIF
    Beep
    Capture
    Auto-Mut
    Internal
    <Internal>

    so, I'm not sure if that is a problem, or one of the above is the functional equivalent of 'mic boost'.

  8. #8
    Join Date
    Jul 2008
    Beans
    19

    Re: disable auto mic gain?

    Quote Originally Posted by jmfal View Post
    Take a look at this, go down to screenshots
    http://askubuntu.com/questions/13181...rking-on-12-04
    The screen shots that I see are of Pulseaudio Volume Control, and I've used that and can lower the headset mic input volume, but then as I've described it pushes itself back up to 100% - I can watch it happening with the PVC panel still open.

    I have tried changing the level and then using the 'sudo alsactl store', but it still pushes the volume back up to 100% over a 20-30 second period [eg not all at once but gradually].

  9. #9
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: disable auto mic gain?

    Are you using skype or a similar app?

    In the alsamixer press F5 and use right arrow key , sometimes there are controls farther to the right off screen.
    turn capture down a little bit.

  10. #10
    Join Date
    Jul 2008
    Beans
    19

    Re: disable auto mic gain?

    Quote Originally Posted by jmfal View Post
    Are you using skype or a similar app?

    In the alsamixer press F5 and use right arrow key , sometimes there are controls farther to the right off screen.
    turn capture down a little bit.
    I'm making calls via gchat/googleplus.
    those are all of the options, even far to the right, off of the screen, when I press f5.
    There is the option to press f6, which lets me select the sound card, and there is an option for my headset "Logitech USB Headset", and if I press that I get 3 tabs: Speaker, <mic>, mic
    the middle tab "<mic> is muted, and the "mic" tab controls the mic volume, and again I can set it low, but it automatically pushes it gradually back up to 100% again.

    also, changing the level for "capture" doesn't change the level of mic input volume [back in the f5 menu]
    Last edited by adelattre; July 20th, 2012 at 07:01 PM. Reason: additional detail

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •