Results 1 to 2 of 2

Thread: problem with mail in terminal

  1. #1
    Join Date
    Jun 2012

    [SOLVED] problem with mail in terminal

    I read about mail in linux and I installed mailutils to send mail in command lines.
    at first when I pressed ctrl+D to end the mail body, mail text ended. but the problem was that it didn't send mails at all. now moreover than that problem, even ctrl+D also does not work and after ctrl+D, I must use ctrl+C to end the mail. I dont know exactly what mistake I did during this time that now my ctrl+D does not work.
    hence 2 questions:
    1- when I want to send email is mailutils enough or I have to install any other service or do I need something like ssmtp?
    2- why ctrl+D does not work but at first it was working? on a virtualbox it works but i dont want to reinstall my ubuntu. is there any program locking my ctrl+D or stopping me after pressing ctrl+D? if there is a program that I should uninstall? how can I recognize it?

    thanks so much

    my terminal:
    aran@arvb:~$ df -h | mail -s "disk space report"
    the body of email
    ^D^D^D^D^D^D^D^D [^D does not work]
    in mail log the common error is:
     stat=Deferred: Connection timed out with
    Last edited by mijonuha; July 15th, 2012 at 03:52 AM.

  2. #2
    Join Date
    Jun 2012

    Re: problem with mail in terminal

    finally solved.
    mail functions with delay. when you send email, it stops for a while. it does not mean that it is waiting for you to press ctrl+D so just be patient for a while.
    I don't know how the other problem solved but after I installed SSMTP and it also failed, and after a while both worked for an unknown reason!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts