Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

  1. #1
    Join Date
    Nov 2010
    Location
    /Earth/Asia/India
    Beans
    218
    Distro
    Ubuntu 14.04 Trusty Tahr

    Arrow ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    I've been trying to install ia32-libs from Synaptic after upgrading to Precise
    I get this :
    Code:
    (Reading database ... 301842 files and directories currently installed.)
    Unpacking libsdl1.2debian:i386 (from .../libsdl1.2debian_1.2.14-6.4ubuntu3_i386.deb) ...
    dpkg-deb (subprocess): data: internal gzip read error: '<fd:4>: invalid code lengths set'
    dpkg-deb: error: subprocess <decompress> returned error exit status 2
    dpkg: error processing /var/cache/apt/archives/libsdl1.2debian_1.2.14-6.4ubuntu3_i386.deb (--unpack):
     short read on buffer copy for backend dpkg-deb during `./usr/lib/i386-linux-gnu/libSDL-1.2.so.0.11.3'
    Selecting previously unselected package libsdl-image1.2:i386.
    Unpacking libsdl-image1.2:i386 (from .../libsdl-image1.2_1.2.10-3_i386.deb) ...
    Selecting previously unselected package libsdl-mixer1.2:i386.
    Unpacking libsdl-mixer1.2:i386 (from .../libsdl-mixer1.2_1.2.11-7_i386.deb) ...
    Selecting previously unselected package libsdl-net1.2:i386.
    Unpacking libsdl-net1.2:i386 (from .../libsdl-net1.2_1.2.7-5_i386.deb) ...
    Selecting previously unselected package libsdl-ttf2.0-0:i386.
    Unpacking libsdl-ttf2.0-0:i386 (from .../libsdl-ttf2.0-0_2.0.9-1.1ubuntu1_i386.deb) ...
    Selecting previously unselected package ia32-libs-multiarch:i386.
    Unpacking ia32-libs-multiarch:i386 (from .../ia32-libs-multiarch_20090808ubuntu36_i386.deb) ...
    And on reinstalling ia32-libs:multiarch from Synaptic using Broken filter i get this :

    Code:
    dpkg: dependency problems prevent configuration of ia32-libs-multiarch:i386:
     ia32-libs-multiarch:i386 depends on libsdl1.2debian; however:
      Package libsdl1.2debian:i386 is not installed.
    dpkg: error processing ia32-libs-multiarch:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsdl-net1.2:i386:
     libsdl-net1.2:i386 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian:i386 is not installed.
    dpkg: error processing libsdl-net1.2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsdl-image1.2:i386:
     libsdl-image1.2:i386 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian:i386 is not installed.
    dpkg: error processing libsdl-image1.2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ia32-libs:
     ia32-libs depends on ia32-libs-multiarch; however:
      Package ia32-libs-multiarch is not installed.
      Package ia32-libs-multiarch:i386 is not configured yet.
    dpkg: error processing ia32-libs (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsdl-mixer1.2:i386:
     libsdl-mixer1.2:i386 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian:i386 is not installed.
    dpkg: error processing libsdl-mixer1.2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsdl-ttf2.0-0:i386:
     libsdl-ttf2.0-0:i386 depends on libsdl1.2debian (>= 1.2.10-1); however:
      Package libsdl1.2debian:i386 is not installed.
    dpkg: error processing libsdl-ttf2.0-0:i386 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     ia32-libs-multiarch:i386
     libsdl-net1.2:i386
     libsdl-image1.2:i386
     ia32-libs
     libsdl-mixer1.2:i386
     libsdl-ttf2.0-0:i386
    Any idea of Short Read problem on amd64 PC ?

  2. #2
    Join Date
    Nov 2010
    Location
    /Earth/Asia/India
    Beans
    218
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Bump

  3. #3
    Join Date
    Dec 2006
    Beans
    13
    Distro
    Ubuntu Studio 9.10 Karmic Koala

    Exclamation Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    I've had the same error as well trying to install Skype on my machine. The 32-bit version won't install because it doesn't overwrite a config file (which I even tried renaming to no avail) and the 64-bit version will not install because "Cannot install ia32-libs". When I force installed the ia32 libs, a whole lot of errors began occuring on my system. Part of me actually wonders if I should have just installed 32-bit Ubuntu on my 64-bit machine...

    FK

  4. #4
    Join Date
    Dec 2011
    Beans
    4

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Quote Originally Posted by Flash Kid View Post
    I've had the same error as well trying to install Skype on my machine. The 32-bit version won't install because it doesn't overwrite a config file (which I even tried renaming to no avail) and the 64-bit version will not install because &quot;Cannot install ia32-libs&quot;. When I force installed the ia32 libs, a whole lot of errors began occuring on my system. Part of me actually wonders if I should have just installed 32-bit Ubuntu on my 64-bit machine...

    FK
    +1 here too, gone back to v2.2

  5. #5
    Join Date
    Jun 2006
    Location
    Goshen, IN
    Beans
    255
    Distro
    Kubuntu 18.04 Bionic Beaver

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    It would be great to find a solution to this problem.

    Oddly, I upgraded a half-dozen 64-bit desktops to Precise, but this problem was only encountered on one of those machines.
    Desktop: Kubuntu 18.04 64-bit Core 2 Quad Q9300 @ 2.5GHz 8GB DDR2 Nvidia GT440
    Nettop: Kubuntu 14.04 64-bit Atom D525 @ 1.8GHz 4GB DDR2 Nvidia ION2
    Netbook: Lubuntu 16.04 Dell Mini 9 2GB RAM

  6. #6
    Join Date
    Nov 2010
    Location
    /Earth/Asia/India
    Beans
    218
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Miraculously solved...Maybe recent updates might have fixed it.

    Thank you all for your interest

  7. #7
    Join Date
    Dec 2007
    Beans
    7

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    I had a similar problem with broken dependencies when trying to install wine and acroread, just after upgrading to 12.04 from 11.04 (passing over 11.10). It seems that some ppa's I had in 11.04 installed newer versions of applications in the system. After upgrading, the remains of these apps seemed to do some mess in the dependencies.

    The solution that seems to work (until now), was found on a german ubuntu board (http://forum.ubuntuusers.de, posts from user Lasall):

    First a downgrade is required and done with the following:
    create the 'preferences' file:
    Code:
    sudo vi /etc/apt/preferences
    and insert the following lines:
    Code:
    Package: *       
    Pin: release a=precise*
    Pin-Priority: 2012
    Pin-Priority must be greater than 1000.

    Then you may downgrade the programs with:
    Code:
    sudo apt-get dist-upgrade
    Then you may install packages that complained about dependencies, like
    Code:
    sudo apt-get install ia32-libs-multiarch
    , or
    Code:
    sudo apt-get install ia32-libs
    Finally, you should remove the file you just created:
    Code:
    rm /etc/apt/preferences
    because else no new updates would be found.

    Hope this helps you too!

  8. #8
    Join Date
    Mar 2006
    Location
    North Carolina
    Beans
    496

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Quote Originally Posted by baijea View Post
    I had a similar problem with broken dependencies when trying to install wine and acroread, just after upgrading to 12.04 from 11.04 (passing over 11.10). It seems that some ppa's I had in 11.04 installed newer versions of applications in the system. After upgrading, the remains of these apps seemed to do some mess in the dependencies.

    The solution that seems to work (until now), was found on a german ubuntu board (http://forum.ubuntuusers.de, posts from user Lasall):

    First a downgrade is required and done with the following:
    create the 'preferences' file:
    Code:
    sudo vi /etc/apt/preferences
    and insert the following lines:
    Code:
    Package: *       
    Pin: release a=precise*
    Pin-Priority: 2012
    Pin-Priority must be greater than 1000.

    Then you may downgrade the programs with:
    Code:
    sudo apt-get dist-upgrade
    Then you may install packages that complained about dependencies, like
    Code:
    sudo apt-get install ia32-libs-multiarch
    , or
    Code:
    sudo apt-get install ia32-libs
    Finally, you should remove the file you just created:
    Code:
    rm /etc/apt/preferences
    because else no new updates would be found.

    Hope this helps you too!
    This solved a problem for me as well about installing prereqs for Wine. However, I'm not sure how you came about the file entries that were needed and why the file needed to be in /etc/apt. I know you reference the German board, but I couldn't get enough out of that to understand why it worked. Do you know why that particular file is what we needed? In particular, why did the file entries allow everything to be downgraded to the current level in Main? I'd really like to understand this, because it is very useful for those of us who use PPA's. I had tried to purge all my PPA's as a solution, but that did not work for me.

  9. #9
    Join Date
    Dec 2007
    Beans
    7

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Hi,

    as far as I know, /etc/apt/preferences is used for pinning; see PinningHowto and also, sorry, German Wiki translated: wiki.ubuntuusers.de/Apt-Pinning. This page is based on
    Code:
    man apt_preferences
    The man page states that
    P (priority) > 1000 causes a version to be installed even if this constitutes a downgrade of the package
    this is what was desired here.

    Glad it could help

  10. #10
    Join Date
    Mar 2006
    Location
    North Carolina
    Beans
    496

    Re: ia32-libs error [Cant install on amd64]ia32-libs error [Cant install on amd64]

    Quote Originally Posted by baijea View Post
    Hi,

    as far as I know, /etc/apt/preferences is used for pinning; see PinningHowto and also, sorry, German Wiki translated: wiki.ubuntuusers.de/Apt-Pinning. This page is based on
    Code:
    man apt_preferences
    The man page states that

    this is what was desired here.

    Glad it could help
    Thanks for the references. I now understand the file entries. The rest makes sense in light of that.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •