Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: Volume acting weird

  1. #21
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: Volume acting weird

    Quote Originally Posted by jmfal View Post
    Yes that is how to install from terminal.

    Run this in a terminal and post results

    Code:
       aplay -l
    And
    Code:
     lsmod
    Code:
    Results for the aplay -l:
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Code:
    Results for lsmod
    
    Module                  Size  Used by
    joydev                 17393  0 
    vesafb                 13516  1 
    rfcomm                 38139  0 
    bnep                   17830  2 
    parport_pc             32114  0 
    bluetooth             158438  10 rfcomm,bnep
    ppdev                  12849  0 
    binfmt_misc            17292  1 
    nvidia              10962290  33 
    snd_hda_codec_conexant    52516  1 
    snd_hda_intel          32765  2 
    snd_hda_codec         109562  2 snd_hda_codec_conexant,snd_hda_intel
    snd_hwdep              13276  1 snd_hda_codec
    snd_pcm                80845  2 snd_hda_intel,snd_hda_codec
    hp_wmi                 13652  0 
    sparse_keymap          13658  1 hp_wmi
    snd_seq_midi           13132  0 
    snd_rawmidi            25424  1 snd_seq_midi
    arc4                   12473  2 
    uvcvideo               67203  0 
    videodev               86588  1 uvcvideo
    snd_seq_midi_event     14475  1 snd_seq_midi
    snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
    psmouse                72919  0 
    serio_raw              13027  0 
    snd_timer              28931  2 snd_pcm,snd_seq
    r852                   17901  0 
    iwl3945                73152  0 
    sm_common              16737  1 r852
    snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
    nand                   49667  2 r852,sm_common
    nand_ids                8547  1 nand
    mtd                    35584  2 sm_common,nand
    nand_bch               13003  1 nand
    bch                    21757  1 nand_bch
    r592                   17808  0 
    iwl_legacy             71134  1 iwl3945
    nand_ecc               13070  1 nand
    memstick               15857  1 r592
    mac80211              436455  2 iwl3945,iwl_legacy
    snd                    62064  13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    cfg80211              178679  3 iwl3945,iwl_legacy,mac80211
    video                  19068  0 
    wmi                    18744  1 hp_wmi
    mac_hid                13077  0 
    soundcore              14635  1 snd
    snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
    lp                     17455  0 
    parport                40930  3 parport_pc,ppdev,lp
    firewire_ohci          40172  0 
    firewire_core          56906  1 firewire_ohci
    crc_itu_t              12627  1 firewire_core
    sdhci_pci              18324  0 
    sdhci                  28241  1 sdhci_pci
    e1000e                140005  0

  2. #22
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Volume acting weird

    Did you add an option to the alsa-base.conf. file, as one op requested.

    What model PC/laptop is having problems?

  3. #23
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: Volume acting weird

    Quote Originally Posted by jmfal View Post
    Did you add an option to the alsa-base.conf. file, as one op requested.

    What model PC/laptop is having problems?
    I didn't see anyone mention alsa-base.conf in here unless if I just skipped over it or is it in another thread?

    HP Pavillion dv6275us Laptop is what's having the issues.

  4. #24
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Volume acting weird

    I'm sorry helping a couple of others with sound problems, and almost same model laptop.
    Run this in a terminal
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Enter password in window, and file will open.
    Scroll to end of file and add this:
    Code:
     options snd-hda-intel model=hp
    Save/close to the etc folder (click on etc>>click save)
    Run these three commands one at a time:
    Code:
      killall pulse audio
                        sudo alsa force-reload
                       pulseaudio  _D
    Don't worry about errors
    Restart laptop
    check in alsamixer that all speakers are not muted
    Play some music
    If still have cracks/pops play with pcm /volumes in mixer
    If that doesn't do it we'll try another one

  5. #25
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: Volume acting weird

    Quote Originally Posted by jmfal View Post
    I'm sorry helping a couple of others with sound problems, and almost same model laptop.
    Run this in a terminal
    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    Enter password in window, and file will open.
    Scroll to end of file and add this:
    Code:
     options snd-hda-intel model=hp
    Save/close to the etc folder (click on etc>>click save)
    Run these three commands one at a time:
    Code:
      killall pulse audio
                        sudo alsa force-reload
                       pulseaudio  _D
    Don't worry about errors
    Restart laptop
    check in alsamixer that all speakers are not muted
    Play some music
    If still have cracks/pops play with pcm /volumes in mixer
    If that doesn't do it we'll try another one
    Alright tried all of that and it's still doing what it's been doing.

  6. #26
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Volume acting weird

    OK then , open that file again

    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    And add this to the other option

    Code:
     options snd-hda-intel position_fix=1
    Restart laptop
    check alsamixer again
    play some music
    again you may have to play with pcm/ volumes
    If that doesn't do it change "1" to "2".

    Also since you say that tha controls jump when adjusting them try playing with the mouse sensitivity. just a thought

  7. #27
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: Volume acting weird

    Quote Originally Posted by jmfal View Post
    OK then , open that file again

    Code:
     gksudo gedit /etc/modprobe.d/alsa-base.conf
    And add this to the other option

    Code:
     options snd-hda-intel position_fix=1
    Restart laptop
    check alsamixer again
    play some music
    again you may have to play with pcm/ volumes
    If that doesn't do it change "1" to "2".

    Also since you say that tha controls jump when adjusting them try playing with the mouse sensitivity. just a thought
    Tried 1 and that didn't work so I changed it to 2 and then rebooted and it didn't work either.

    When I say the control jumps I don't mean the little arrow or the marker. I'm talking about the actual volume itself jumps alot. Like if I were to have the alsamixer open while I'm moving the volume using the volume bar it stays at 0 until I get to the Unamplified mark. Then it jumps to 23 and then just keeps moving by high amounts like that which makes it difficult to find a good volume to listen to.

    Also if I've got the marker to the farthest left of the sound bar (Set to mute essentially) and then move it to the right once the PCM goes to 100%.

  8. #28
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Volume acting weird

    Let try setting "=hp" to "=auto" in the first option

    If no, then change "2" back to"1" (no quotes)
    restart
    check alsamixer
    try some music

  9. #29
    Join Date
    Jun 2010
    Beans
    Hidden!

    Re: Volume acting weird

    Quote Originally Posted by jmfal View Post
    Let try setting "=hp" to "=auto" in the first option

    If no, then change "2" back to"1" (no quotes)
    restart
    check alsamixer
    try some music
    Tried doing hp and auto for both 1 and 2 and it's still doing it.

    Just to make sure I had the options added properly I'm going to post my alsa-base.conf here:

    Code:
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2
    options snd-hda-intel model=hp
    options snd-hda-intel position_fix=2

  10. #30
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Volume acting weird

    Was the first option (3rd from bottom of file) there or did you add it?
    If you added it, remove it (don't comment out (#))
    It is already in the section above.

    You can try changing (=hp) to (=laptop-hp)

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •