Results 1 to 7 of 7

Thread: C89 cant run the executable file

Threaded View

  1. #1
    Join Date
    Feb 2007
    Location
    NZ
    Beans
    89
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    C89 cant run the executable file

    I've created a simple program using geany. It compiles and builds without hassle. However when I try to run the program I get
    Code:
    ./geany_run_script.sh: 5: ./testing: Permission denied
    I tried running it through the terminal and get a similar responce
    Code:
    bash: ./testing: Permission denied
    and when I double click on the executable file from the file browser I get
    Code:
    There is no application installed for executable files
    I did some googling and tried a few things without any success
    Code:
    chmod +x testing.ext
    I also right clicked the file>>properties>>permissions>> and tried to select "Allow executing file as program". However any changes that I make under the permissions tab instantly change back to the original.

    NOTE: This is on a separate partion. If i save the .c file onto my Ubuntu partition everything works fine.
    Last edited by scorpious; July 11th, 2012 at 06:13 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •