Results 1 to 8 of 8

Thread: Alsa mixer capture feature always muted

  1. #1
    Join Date
    Aug 2009
    Beans
    22

    Alsa mixer capture feature always muted

    Hi

    I've recently upgraded my ubuntu server to the latest 12.04 version. Almost everything is fine but experiencing few painful issues. Namely my alsa mixer shows capture features always muted, or rather turn down completely after restart. Each time I have turn up the volume to be able to use skype.
    How can I set the volume of the capture input for good?

  2. #2
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alsa mixer capture feature always muted

    Welcome to Ubuntu.

    I'm pretty sure that capture is muted at startup by default.

    I tried looking for a work-around or script to add, but .........

  3. #3
    Join Date
    Aug 2009
    Beans
    22

    Re: Alsa mixer capture feature always muted

    My previous version 10.04 LTS was fine about that so there is probably a file containing this settings. Or we've got a step back here. For instance playback is alway on the level of volume I set last time.

    Besides what would be the reason to mute anything by default.

  4. #4
    Join Date
    May 2009
    Location
    rocket city,al,usa
    Beans
    659
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alsa mixer capture feature always muted

    Capture is line input and there is for the most part no incoming sound at startup

    I can't help thats the way it is .
    I can turn up my mic and line in and restart and both will be muted at restart

  5. #5
    Join Date
    Mar 2011
    Beans
    182

    Re: Alsa mixer capture feature always muted

    You might be able add "amixer" to a startup/login script:

    Try:
    $ amixer scontrols
    $ amixer --help

    -->
    $ amixer sset Capture 100

    I'm not sure about the "100" value.
    Last edited by flemur13013; July 11th, 2012 at 03:19 AM.

  6. #6
    Join Date
    Sep 2008
    Beans
    37

    Re: Alsa mixer capture feature always muted

    open a command windows

    use alsamixer to adjust your settings
    and use
    Code:
    sudo alsactl store

  7. #7
    Join Date
    Aug 2009
    Beans
    22

    Re: Alsa mixer capture feature always muted

    and what is the location of the file where those settings are being saved by the ALSACTL command ? It is still not working although it looks like settings are being saved, I've got no error and any other feedback.

  8. #8
    Join Date
    Aug 2006
    Beans
    28

    Re: Alsa mixer capture feature always muted

    Quote Originally Posted by beterhans View Post
    open a command windows

    use alsamixer to adjust your settings
    and use
    Code:
    sudo alsactl store
    Thank you, that helped me too.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •