Page 5 of 5 FirstFirst ... 345
Results 41 to 48 of 48

Thread: Acer Aspire One 725 Elantech Touchpad not working

  1. #41
    Join Date
    Jan 2013
    Beans
    3

    Re: Acer Aspire One 725 Elantech Touchpad not working

    Follow-up on my previous post: the touchpad worked only for a single boot. I suspended the computer, and when it resumed, the Touchpad tab was gone from the system settings (as was the touchpad itself). None of the solutions mentioned in this thread have worked since then (rebooted many times).

    BTW, when booting in Windows, the touchpad works flawlessly, ruling out some hardware failure.

  2. #42
    Join Date
    Dec 2012
    Beans
    16

    Re: Acer Aspire One 725 Elantech Touchpad not working

    thanks with this one. it works on mine.

  3. #43
    Join Date
    May 2013
    Beans
    2

    Re: Acer Aspire One 725 Elantech Touchpad not working

    Observations:
    When you press the Fn+F7 in Ubuntu (13.04), it show an icon that the track pad has been enable or disable but nothing happen.
    Its work well in windows however.
    Now in Windows press the Fn+F7 to disable the track pad and reboot to Ubuntu, then again press the Fn+F7 to enable the track pad again and now it work.
    It will work after stand by but shut down mean to do the whole process again.

    It may not be the best solution but it works for my and I hope that the Ubuntu Developers them self can see this and fix it properly in their next update or upgrade

  4. #44
    Join Date
    Dec 2010
    Beans
    1

    Re: Acer Aspire One 725 Elantech Touchpad not working (SOLVED WITH NO HACKS!)

    Quote Originally Posted by NihilisticNabarlek View Post
    FIXED WITH NO HACKS YEAH!!!!!


    Finally got Elantech touchpad working perfectly. Follow the following instructions, reboot and you're golden

    ELANTECH TOUCHPAD

    In TERMINAL type the following:
    Code:
    sudo gedit /etc/X11/xorg.conf
    Then COPY and PASE the following in the file. Save it, reboot and voila it works, multitouch and all!
    Code:
    Section "InputClass"
        Identifier "ETPS/2 Elantech Touchpad"
        MatchProduct "ETPS/2 Elantech Touchpad"
        MatchDevicePath "/dev/input/event*"
        Driver "synaptics"
        Option "TapButton1" "1"
        Option "TapButton2" "3"
        Option "TapButton3" "2"
        Option "VertTwoFingerScroll" "1"
        Option "HorizTwoFingerScroll" "1"
        Option "CoastingSpeed" "10"
        Option "EdgeMotionMinZ" "30"
        Option "EdgeMotionMaxZ" "40"
        Option "EdgeMotionMinSpeed" "100"
        Option "EdgeMotionMaxSpeed" "400"
        Option "FingerLow" "9"
        Option "FingerHigh" "12"
        Option "EmulateMidButtonTime" "0"
        Option "ClickPad" "True"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    EndSection
    WOW..KUDOS to this!

    I have had two Acer Netbooks, starting from 2008. My oldest one was a ZG5. The one I currently have is the A0725. I have NEVER had a fully functioning touchpad in Linux with these netbooks until now! I have had limited functionality in the past using the modprobe.d/ psmouse fix listed here, but I have always had to enable the mouse at startup with the Fn+F7 key. I recently installed Linux Mint 13 (64 bit) on my A0725 and found that the mouse did not work at all at initial installation. I again got mixed results with the modprobe.d/ psmouse change so I tried the above solution out and it worked. This XORG solution did not enable the touchpad automatically at startup, but I also followed the advice to add "blacklist acer-wmi" to the blacklist options (also listed above). So now the touchpad loads at startup AND has full functionality.

    This worked for me, but as described at the beginning of this thread, my elantech touchpad was listed in "xinput list" at the terminal.

  5. #45
    Join Date
    May 2013
    Beans
    2

    Re: Acer Aspire One 725 Elantech Touchpad not working

    Update:

    I didn't do any of the configuration they say jet it work for me.
    OK, my new finding is that after a shutdown is that I don't need to start windows any more but I must press Fn + F7 before log in and the track-pad will star to work again.
    If you do log in then the Fn + F7 will not work!

    People just tested out and post to let the rest of us to know, thx

  6. #46
    Join Date
    Jan 2009
    Location
    Palo Alto, CA
    Beans
    42

    Re: Acer Aspire One 725 Elantech Touchpad not working

    Quote Originally Posted by frank75riz View Post
    Originally Posted by NihilisticNabarlek

    this works..just did this and ghadzooks...it works

    1. Open the Terminal
    2. cd /etc/modprobe.d/
    3. gksudo gedit options.conf
    4. In the text editor (which will pop up) type without the quotes
    "options psmouse proto=imps"
    5. Save the file and close the terminal
    6. sudo modprobe -r psmouse
    7. sudo modprobe psmouse

    THANK YOU NihilisticNabarlek
    This didn't seem to fix the problem for me (Aspire One 722, problem just started a fe ow days ago....). How do I back this hack out? That is how do I revert to the Elantech stuff?

    BTW, touchpad works fine when the netbook is not plugged into power. I think its actually some sort of grounding problem as described here: http://askubuntu.com/questions/30997...er-is-pluggged
    ______Ron

  7. #47
    Join Date
    Jan 2014
    Beans
    4

    try 12.04.4

    To everybody who couldnt get it with the xorg.conf edit solution, here may be the trick :
    coming from this http://ubuntuforums.org/showthread.php?t=2198715 i am pretty close to say i would bet that all ur problems are gone either :

    * Installing the Daily Build of 12.04.4 now,
    * or wait till the sixth (2 days) till the 12.04.4 officialy arrivies (-:

    u may test this with a simple live usb stick
    http://cdimage.ubuntu.com/precise/daily-live/current/
    13.10 should also handle elantech nice.

    Have Fun (-:

  8. #48
    Join Date
    Feb 2014
    Beans
    10

    Re: Acer Aspire One 725 Elantech Touchpad not working

    Hello!

    The problem is still present with the Samsung RV515-A03US in 12.04.4 (3.8.0-34 kernel). Adding that options.conf file to directory /etc/modprobe.d was the fix here.

    73 DE N4RPS
    Rob

    Linux Lite 1.0.8
    http://www.linuxliteos.com

Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •