Results 1 to 10 of 10

Thread: serial port open fails and takes 100% cpu

Threaded View

  1. #1
    Join Date
    Mar 2012

    serial port open fails and takes 100% cpu

    I've downloaded the source code for obdgpslogger and compiled it on my 12.04 machine.

    Everything compiles fine, but when I run the obdgpslogger I have two problems when I run the program with this command

    ./obdgpslogger -s /dev/ttyUSB0 -b 9600 -a 5 -i temp,map,rpm,vss,throttlepos,sparkadv
    1. The program/computer doesn't communicate correctly witht the ELM chip. I keep on getting 'timeout' for all the calls to write to the serial and wait for a response. Looking at the source code shows that the program is not getting a response back from the chip when it sends a command to it.
    While it is in the openserial() function this is the stdout.

    Opening serial port /dev/ttyUSB0, this can take a while
    Successfully connected to serial port. Will log obd data
    Successfully connected to gpsd. Will log gps data
    Couldn't get obd bytes for cmd 00
    GPS acquisition complete
    But it isn't successfully connected to the serial port.

    If I open putty and set it up with the correct settings than I can communicate with the chip manually.

    Any ideas on why this isn't working?

    2. While my computer is trying to communicate with the ELM chip, the obdgpslogger takes 100% of the cpu.

    Not sure where to start with this one to debug the problem. Any ideas??
    Attached is the output of this command.
    $ cpufreq-info
    Attached Images Attached Images
    Attached Files Attached Files


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts