Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: 12.04 AMD Graphics driver post-release updates won't install

  1. #1
    Join Date
    Jun 2012
    Beans
    19

    12.04 AMD Graphics driver post-release updates won't install

    Hello,

    I've installed the FGLRX graphics driver on my Dell Inspiron 15R (M5010) laptop, but normal Ubuntu desktop won't load so I have to run Ubuntu 2D. I've tried to install the Driver's post-release updates, but it fails to install. The terminal tells me to check /var/log/jockey.log but I'm an Ubuntu newbie and I have no idea what all that text means. Any help please?
    Last edited by andizam; July 1st, 2012 at 02:12 AM.

  2. #2
    Join Date
    Oct 2008
    Beans
    32

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Same problem here. Do a

    sudo apt-get purge fglrx-updates amdcccle-updates

    and then install the one that doesn't say post-release updates. I filed a bug report on it. Subscribe and click that it effects you and hopefully it will get noticed.

    https://bugs.launchpad.net/ubuntu/+s...y/+bug/1019007

  3. #3
    Join Date
    Jun 2012
    Beans
    19

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Thank you! Will this help me boot into normal Ubuntu desktop, or will I still need to use Ubuntu 2D?

    PS: When I ran the purge command, it said amdcccle-updates didn't exist. I ran the purge with only fglrx-updates and it work, but many error messages came up in terminal. Should I worry about this? And I subscribed to the issue, hopefully it gets noticed!

  4. #4
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: 12.04 AMD Graphics driver post-release updates won't install

    The fglrx-updates and fglrx-amdcccle-updates packages have both been problematic for some users.

    I would remove them this way:

    Code:
    sudo apt-get remove --purge fglrx*
    I have been able to get the -updates driver to install and work properly, but the Catalyst Control Center will not start.

    Installing fglrx and fglrx-amdcccle will get you to normal operation with 3D if you want the proprietary driver.
    Last edited by QIII; July 1st, 2012 at 05:01 AM.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    This universe is crazy. I'm going back to my own.

  5. #5
    Join Date
    Jun 2012
    Beans
    19

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Thank you! It manages to install but with errors. Maybe you understand what's going on?

    Code:
    sudo apt-get install fglrx-updates
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following extra packages will be installed:
      fglrx-amdcccle-updates
    The following NEW packages will be installed:
      fglrx-amdcccle-updates fglrx-updates
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/45.1 MB of archives.
    After this operation, 129 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Selecting previously unselected package fglrx-updates.
    (Reading database ... 171393 files and directories currently installed.)
    Unpacking fglrx-updates (from .../fglrx-updates_2%3a8.960-0ubuntu1_i386.deb) ...
    Selecting previously unselected package fglrx-amdcccle-updates.
    Unpacking fglrx-amdcccle-updates (from .../fglrx-amdcccle-updates_2%3a8.960-0ubuntu1_i386.deb) ...
    Processing triggers for ureadahead ...
    Setting up fglrx-updates (2:8.960-0ubuntu1) ...
    update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.
    update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl64.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/libaticalcl.so because associated file /usr/lib32/fglrx/libaticalcl.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/libaticalrt.so because associated file /usr/lib32/fglrx/libaticalrt.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group i386-linux-gnu_gl_conf is broken.
    update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl64.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl64.icd (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/libaticalcl.so because associated file /usr/lib32/fglrx/libaticalcl.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: warning: skip creation of /usr/lib32/libaticalrt.so because associated file /usr/lib32/fglrx/libaticalrt.so (of link group i386-linux-gnu_gl_conf) doesn't exist.
    update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
    update-initramfs: deferring update (trigger activated)
    Loading new fglrx-updates-8.960 DKMS files...
    First Installation: checking all kernels...
    Building only for 3.2.0-26-generic-pae
    Building for architecture i686
    Building initial module for 3.2.0-26-generic-pae
    Done.
    
    fglrx_updates:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/3.2.0-26-generic-pae/updates/dkms/
    
    depmod....
    
    DKMS: install completed.
    update-initramfs: deferring update (trigger activated)
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Setting up fglrx-amdcccle-updates (2:8.960-0ubuntu1) ...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-3.2.0-26-generic-pae
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place

  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Warnings, but no errors.

    Looks like it installed.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    Jun 2012
    Beans
    19

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Oh. I assumed they were errors because my laptop still refuses to boot into a normal (Unity) Ubuntu desktop, and I'm forced to use Unity 2D.

  8. #8
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Do you have hybrid graphics?
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    This universe is crazy. I'm going back to my own.

  9. #9
    Join Date
    Jun 2012
    Beans
    19

    Re: 12.04 AMD Graphics driver post-release updates won't install

    No, I'm fairly sure Radeon HD 4250 is my only video card.

  10. #10
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: 12.04 AMD Graphics driver post-release updates won't install

    Would you do

    Code:
    /usr/lib/nux/unity_support_test -p
    and

    Code:
    fglrxinfo
    and post back the results for each?
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    This universe is crazy. I'm going back to my own.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •