Results 1 to 5 of 5

Thread: Asus T91 12.04 installation

  1. #1
    Join Date
    Jan 2011

    Asus T91 12.04 installation

    38 pages of posts seemed a bit much so here's a brand new Asus T91 thread. Yeaaaayyyy.

    On initial login screen is distorted (desktop in top half only). It may be necessary to select "recovery mode" at the grub menu and then resume. It may also be necessary to go into terminal (ctrl+alt+f1) & restart X
    sudo service lightdm restart
    [Q: why does this restart X?]

    1) To get boot into graphical environment working:

    gksudo leafpad /etc/default/grub
    edit line starting GRUB_CMDLINE_LINUX_DEFAULT to read:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet console=tty1"
    save and exit, then update grub with

    sudo update-grub

    (Fixes adapted by trial and error from Poulsbo driver wiki)

    (At some point during this process I was prompted to update the system - this didn't seem to be critical but what do I know.)

    Now the T91 boots into the Xubuntu desktop, and:
    - wifi works
    - Youtube plays acceptably in window
    - Volume keys work. Webcam works (tested in Cheese).
    - Speakers work
    - Headphones work

    Problems so far:
    - Brightness keys don't work FIXED
    - Display broken after restarting from suspend FIXED
    - Touchscreen calibration off slightly FIXED
    - Microphone doesn't appear to work (tested in Audacity)
    - Screen won't rotate (lost cause with current GMA 500 driver?)
    - Youtube playback choppy fullscreen
    Last edited by onebir; June 28th, 2012 at 01:56 PM.

  2. #2
    Join Date
    Jan 2011

    Re: Asus T91 12.04 installation

    1) FAILED: the rejigged gsd-backlight-helper from here without success.

    What I tried:
    1) Following the post exactly, eg
    sudo cp gsd-backlight-helper /usr/lib/gnome-settings-daemon
    renamed the file to "gnome-settings-daemon".

    2) FAILED: I noticed a folder called "gnome-settings-daemon-3.0"; I thought perhaps gsd-backlight-helper should be there. But after moving it in and rebooting no change.

    3) FAILED: Following the wiki I added "acpi_osi=Linux acpi_backlight=vendor" to the line starting GRUB_CMDLINE_LINUX in

    Now the brightness keys bring up a little display, but the brightness doesn't change.

    4) FAILED: Adding "acer_wmi.blacklist=yes" to the line mentioned in 3. So I deleted it again.

    5) Finally... SUCCESS: using Snow Dimon's method.

    cd /
    sudo leafpad .backlight
    Paste in the script to handle the backlight keys:
    while [ "$1" != "exit" ] ; do
     a=$(cat /sys/class/backlight/eeepc/brightness)
    echo $n > /sys/class/backlight/psb-bl/brightness
    sleep 0.5
    save, and make the script executable:
    sudo chmod 755 /.backlight
    This script needs to be able to write to the brightness it mentions. But this is a system file that's created afresh (?) each time we boot. So we need to enable writing to it each time we boot, by modifying rc.local, which runs each time we boot (pretty much?):
    sudo leafpad /etc/rc.local
    Above the exit line paste in this:
    sudo chmod 666 /sys/class/backlight/psb-bl/brightness
    Now set the .brightness script to run on startup. (I used Settings->Settings manager->Session and startup-> Application Autostart. Scroll down to see the "Add" button, click and give a name and more importantly the path to the backlight script,
    When I restarted this worked for me.
    Last edited by onebir; June 27th, 2012 at 03:41 PM.

  3. #3
    Join Date
    Jan 2011

    Re: Asus T91 12.04 installation

    Fix documented here works fine.

  4. #4
    Join Date
    Jan 2011

    Re: Asus T91 12.04 installation

    Touchscreen calibration:

    1) Failed: instructions using xinput-calibrator here.

    (For reference, the output from the calibrator was:
    Option "Calibration" "1685 63721 2703 64807")

    2) SUCCESS: following these steps.

    But use xinput set-int-prop 9 "Evdev Axis Calibration" 32 300 7900 400 8000 for (near?) perfect calibration.
    Last edited by onebir; June 28th, 2012 at 09:35 AM.

  5. #5
    Join Date
    Jan 2011

    Re: Asus T91 12.04 installation

    Screen rotation
    1) Failed xrandr -o left produces this error:
    X Error of failed request: BadMatch (invalid parameter attributes)
    Major opcode of failed request: 149 (RANDR)
    Minor opcode of failed request: 2(RRSetScreenConfig)
    Serial number of failed request: 14
    Current serial number in output stream: 14
    /etc/acpi/ uses xrandr so there's no point fiddling with it until this is fixed.

    It seems xrandr needs a --output + argument. Tried:
    $xrandr --output default -o left
    xrandr: failed to get size of gamma for output default
    $xrandr --output default --rotate left
    xrandr: output default cannot use rotation "left" reflection "none"
    $xrandr --output default --rotate left --reflect (normal|x|y|xy)
    xrandr: output default cannot use rotation "left" reflection ("none"|"X axis"|"Y axis"|"X and Y axis")
    Last edited by onebir; June 28th, 2012 at 12:59 PM.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts