ok two problems, they may be related.

1- first i downloaded a bunch of ubuntu updates
(via the automatic notifier). Now my operating password does not work.

i made this discovery when attempting to download a new software package. i was asked for my password, but it didnt work. i tried several times. then tried other packages, then tried to open the synaptic package manager. at all points i was asked to type my password, the computer failed to recognize it.
'Your authentication attempt was unsuccessful'.

ok, i know my password. ive used it for years. it was authenticating fine before the updates occurred.

2- evertime i turn on my computer/login i am given this message from ubuntu.

'Enter password to unlock your login keyring

The login keyring did not get unlocked when you logged into your computer'

to which i type my password. it happens about 30 30 seconds after ubuntu has finished start up, and im free to do what i like. its been happening for a few days.

are the two related? etherway they are both very serious issues.