Page 1 of 5 123 ... LastLast
Results 1 to 10 of 48

Thread: The complete mess that is called Abiword

  1. #1
    neu5eeCh is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    Dec 2009
    Beans
    912
    Distro
    Ubuntu

    The complete mess that is called Abiword

    Rumor has it that Ubuntu accidentally released an unstable "development" version of Abiword with 12.04.

    Whatever the reason, it's a complete disaster.

    Can any of you recommend a PPA to bring Abiword back to stability? - or is there a better solution?

  2. #2
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    13,000
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: The complete mess that is called Abiword


  3. #3
    neu5eeCh is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    Dec 2009
    Beans
    912
    Distro
    Ubuntu

    Re: The complete mess that is called Abiword

    Unfortunately, this PPA doesn't appear to offer an update for precise. Is there a way to tweak this?


  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    13,000
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: The complete mess that is called Abiword

    You could try removing your current version and installing the 11.10 version from here. Go to the bottom of the page and click on the link appropriate for your system's architecture.

  5. #5
    neu5eeCh is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    Dec 2009
    Beans
    912
    Distro
    Ubuntu

    Abiword development seems dead.

    From what I can tell, Abiword is looking dead. The Stable PPA hasn't been updated in over two years and the Wikipedia article seems to imply that the Ubuntu version is based on a three year old version. Seems to be as dead as AWN. Oh well... moving on.

  6. #6
    Join Date
    Apr 2007
    Location
    NH USA
    Beans
    1,434
    Distro
    Ubuntu Development Release

    Re: The complete mess that is called Abiword

    Quote Originally Posted by VTPoet View Post
    Unfortunately, this PPA doesn't appear to offer an update for precise. Is there a way to tweak this?
    Yes, many times you can edit the sources from "precise" to "oneiric" and it will work. If you have Synaptic installed, it's easily done from Settings/Repositories/Other Software. Select the ppa, click "edit", change "precise" to "oneiric".

    Reload the repos in Synaptic (or sudo apt-get update) and see how it goes.

  7. #7
    Join Date
    Jun 2012
    Beans
    10

    Re: The complete mess that is called Abiword

    You could simply install libreoffice. It has all components that abiword has and more. Its a small mimic of microsoft office and is a subtree of open office.

  8. #8
    Join Date
    Mar 2007
    Beans
    50

    Re: The complete mess that is called Abiword

    LibreOffice is a fork of OpenOffice, not a subtree. When the community (rightly) suspected that Oracle wouldn't support OpenOffice any more than they did OpenSolaris, they forked the source code and started putting in all the development patches that Sun had been essentially sitting on for a couple of years. It's available in the repositories and can be installed with your choice of software management packages.

    Unfortunately, it's a fair bit slower to launch than Abiword, and has a lot of features that I have no use for. WordPad may be a Microsoft program, but it was pretty much all the word processor I ever needed. Who's going to build me something like that?
    When you make laws to control foolish others, you forge the chains that will be used to control you.
    My blog
    my pre-blog website

  9. #9
    Join Date
    Apr 2008
    Beans
    11,576

    Re: The complete mess that is called Abiword

    I'm trying to figure out what to do here also. I've used Abiword for a very long time, originally in Windows ME, and a quick google search found this bug:

    https://bugs.launchpad.net/ubuntu/+s...cs/+bug/960089

    It's now closed and marked invalid due to the bug filer not following up but of importance:

    Dear Christopher and canoncial,

    It iflls me with frustration that Canonical chose to distribute our
    development version of abiword, abiword-2.9.2 with your 12.04 LTS
    distribution. This was done without any consultation with the abiword
    community AT ALL. Please revert to version 2.8.6. Failing this please
    advise how we will be able to support our users on Ubuntu as Canoncial
    does not release updates either.

    Best regards,

    Martin Sevior
    A bit more googling tells me that Martin Sevior is connected to the abiword project so I'll continue to look into this and hopefully find a solution by the time 12.04.1 releases

    BTW the Oneiric version worked flawlessly for me.

  10. #10
    Join Date
    Apr 2008
    Beans
    11,576

    Re: The complete mess that is called Abiword

    Another bug report:

    https://bugs.launchpad.net/ubuntu/+s...cs/+bug/991399

    I found that one through Ubuntu answers:

    http://askubuntu.com/questions/14226...ity-in-abiword

    Same basic answer:

    Hi everyone,

    AbiWord-2.9.2 is very much a development release and should never have
    been included in Ubuntu 12.04. Please revert to abiword-2.8.6

    Best regards,

    Martin Sevior
    So I need to do two things:

    #1: Figure out how to downgrade, won't be super straight forward

    #2: Make a feature request for 12.04.1. I've done it before but I'll have to put my thinking cap on to try and remember how

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •