Results 1 to 10 of 11

Thread: error is 4shared desktop

Hybrid View

  1. #1
    Join Date
    Oct 2011
    Kubuntu 12.04 Precise Pangolin

    error is 4shared desktop

    I have this error
    subhi@subhi-pc:~$ desktop4shared 
    Guessing JAVA_HOME...
    Assuming JAVA_HOME=/usr/lib/jvm/java-6-openjdk-amd64
    Starting desktop4shared...
    19:59:43 [AWT-EventQueue-0] INFO  Initialize - UI Initialized in 215
    19:59:49 [main] ERROR common.GlobalExceptionHandler - Uncaught exception in thread [main] : the number of constructors during runtime and compile time for groovy.util.FactoryBuilderSupport do not match. Expected 3 but got 2
    java.lang.IncompatibleClassChangeError: the number of constructors during runtime and compile time for groovy.util.FactoryBuilderSupport do not match. Expected 3 but got 2
            at<init>(ApplicationBuilder.groovy:26) ~[griffon-rt-0.9.jar:0.9]
            at<init>(ApplicationBuilder.groovy) ~[griffon-rt-0.9.jar:0.9]
            at griffon.builder.UberBuilder.uberInit(UberBuilder.groovy:73) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.CompositeBuilderHelper.handleLocalBuilder(CompositeBuilderHelper.groovy:86) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.CompositeBuilderHelper$handleLocalBuilder.callStatic(Unknown Source) ~[na:na]
            at org.codehaus.griffon.runtime.util.CompositeBuilderHelper$_createBuilder_closure1.doCall(CompositeBuilderHelper.groovy:51) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.CompositeBuilderHelper.createBuilder(CompositeBuilderHelper.groovy:50) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.CompositeBuilderHelper$ Source) ~[na:na]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.buildMVCGroup(GriffonApplicationHelper.groovy:233) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper$buildMVCGroup.callStatic(Unknown Source) ~[na:na]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:191) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper$createMVCGroup$0.callStatic(Unknown Source) ~[na:na]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper.createMVCGroup(GriffonApplicationHelper.groovy:171) ~[griffon-rt-0.9.jar:0.9]
            at org.codehaus.griffon.runtime.util.GriffonApplicationHelper$ Source) ~[na:na]
            at griffon.core.BaseGriffonApplication$_startup_closure2.doCall(BaseGriffonApplication.groovy:178) ~[griffon-rt-0.9.jar:0.9]
            at griffon.core.BaseGriffonApplication.startup(BaseGriffonApplication.groovy:177) ~[griffon-rt-0.9.jar:0.9]
            at griffon.core.GriffonApplication$ Source) ~[na:na]
            at griffon.swing.SwingApplication.startup(SwingApplication.groovy) ~[griffon-rt-0.9.jar:0.9]
            at griffon.core.GriffonApplication$startup.callCurrent(Unknown Source) ~[na:na]
            at griffon.swing.SwingApplication.realize(SwingApplication.groovy:61) ~[griffon-rt-0.9.jar:0.9]
            at griffon.application.StandaloneGriffonApplication$ Source) ~[na:na]
            at griffon.swing.SwingApplication.main(SwingApplication.groovy:107) ~[griffon-rt-0.9.jar:0.9]

  2. #2
    Join Date
    Aug 2011

    Re: error is 4shared desktop

    i have the same error , anybody can help us?

  3. #3
    Join Date
    Jul 2012

    Angry Re: error is 4shared desktop

    yo man !!!

    I have this same problem.
    The log i got here is just the same that appears to me.....
    I send an email for the support of 4shared and for the maintainer of the package...but it's been one month and a answer...
    If anyone get any clue about this, please help....

    Seeya !!

  4. #4
    Join Date
    Apr 2007

    Re: error is 4shared desktop

    Simply looking at the backtrace, it looks like there's a binary incompatibility with groovy. With some extra linebreaks;
    java.lang.IncompatibleClassChangeError: the number of constructors
    during runtime and compile time for groovy.util.FactoryBuilderSupport
    do not match. Expected 3 but got 2
    Some quick Googling reveals;
    Quote Originally Posted by Guillame Laforge
    [...] this [third] constructor was already deprecated in Groovy 1.6 (in some 1.5.x release).
    We kept the deprecation of that constructor in two major releases.
    It's indeed only in Groovy 1.8 that we removed that deprecation, and this happened already in June 2010!
    I'm not sure we should follow the JDK approach that keeps all the deprecated things forever
    You don't mention what Kubuntu release you're running, but the precise repository version of groovy is 2.0.0~beta2+isreally1.8.6-0ubuntu1.

    What you want to do is to downgrade it to an earlier (< 1.8) version, such as 1.7 that was released with 11.10 oneiric. The easiest way is to download that package from and manually install the deb file. (Admittedly you could instead add some oneiric repositories to your apt sources, if you prefer that approach.)

    Apologies if this is a bit basic and obvious, but for Googlers who don't know the dance; download the .deb, find it in Dolphin, and double-click it to open up QApt for installation. Or do it from a terminal;
    $ sudo dpkg -i /path/to/groovy_1.7.10-2_all.deb
    At this point your desktop4shared should work properly -- or at the very least, crash with some other error. ; 3

    The next big hurdle is getting package managers to not upgrade the package; there is an update in the precise repositories, after all. They don't always listen to eachothers' settings but the following should be enough;
    $ printf 'Package: groovy\nPin: version 1.7*\nPin-Priority: 1001\n' | sudo tee /etc/apt/preferences.d/groovy
    $ echo groovy hold | sudo dpkg --set-selections
    $ sudo aptitude hold groovy  # you may not have aptitude installed, in which case this won't work -- ignore if so
    If you're using some other exotic package manager (such as smartd), look to its documentation for hints on how to pin/hold packages. Hopefully it should then stay at 1.7 at package upgrades.

  5. #5
    Join Date
    Jul 2012

    Talking Re: error is 4shared desktop

    Yo Zorael !!!!

    Thanks for your help man....
    I make the downgrade as you sugest and its realy works !!

    thanks a lot man !!!..=)...

  6. #6
    Join Date
    Jul 2010

    Re: error is 4shared desktop

    Worked for me too, thanks a bunch!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts