Results 1 to 4 of 4

Thread: apache 2.4 and a2ensite

  1. #1
    Join Date
    Apr 2012
    Beans
    29

    apache 2.4 and a2ensite

    hi,
    i compiled Apache 2.4 from source but i can't enable any site through a2ensite, i get only:

    ERROR: Site xyxy does not exist!

    i added this line into httpd.conf: Include vhosts/*

    and all my vhosts are stored in /usr/local/apache2/vhosts

    for example there is xxy.vhost

    <VirtualHost *:80>
    DocumentRoot /var/www/xxy.tld/public

    ServerName xxy.tld
    ...

    if i try a2ensite xxy.vhost:
    ERROR: ...

    any idea? thank you.

  2. #2
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,747
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: apache 2.4 and a2ensite

    I've never installed Apache from source, but your include directive likely needs a complete path.

    Looking at my /etc/apache2/apache2.conf I have the following line:

    Code:
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  3. #3
    Join Date
    Apr 2012
    Beans
    29

    Re: apache 2.4 and a2ensite

    Quote Originally Posted by volkswagner View Post
    I've never installed Apache from source, but your include directive likely needs a complete path.

    Looking at my /etc/apache2/apache2.conf I have the following line:

    Code:
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/
    hi, i tried but no change.

  4. #4
    Join Date
    Apr 2012
    Beans
    29

    Re: apache 2.4 and a2ensite

    LOL!

    this is very embarrassing but,

    if forgot to copy www stuff to the directory

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •