Results 1 to 7 of 7

Thread: HP Printer gets “Device Communication error (5012)”

  1. #1
    Join Date
    Aug 2007
    Beans
    685
    Distro
    Xubuntu 14.04 Trusty Tahr

    HP Printer gets “Device Communication error (5012)”

    I have spent considerable time getting my HP Photosmart C6180 all-in-one (printer, fax, scanner, copier) working on Lucid. I have seen posts indicating that other people were having similar problems so I thought I would post the solution.

    I discovered that the hp-setup (no parameters) GUI and hp-toolbox both set the printer URI to “hp:/net/Photosmart_C6100_series?zc=HP547597” rather than to “hp:/net/Photosmart_C6100_series?ip=192.168.0.31” as it should be. On Lucid you can go to Mainmenu>System>Administration>Printing (system-config-printing if you need to install it with Synaptic) and change this. Right click on the printer icon, select Properties and edit the URI box. For the printer (not for a printer/fax) you can also set the URI to "socket://<your printer URL>:9100" and it will work. However, if you have a printer/fax you need to use “hp:/net/Photosmart_C6100_series?zc=HP547597”. Also the fax device (the icon Properties) must have a Make/Model of “HP Fax hpcups”. This cannot be changed with system-config-printing. The only way I found to get the fax to work was to use

    hp-setup -i 192.168.0.31

    or to use the
    Code:
    hp-toolbox
    GUI. The toolbox sets the URI wrong, but it can be corrected in system-config-printing. The Model/Make parameters are set correctly by toolbox. Note that my printer URL is 192.168.0.31. Yours will be different.

    I am about to try this same setup on Precise Pangolin 12.04.

    Hope this helps somebody.

  2. #2
    Join Date
    Aug 2007
    Beans
    1

    Re: HP Printer gets “Device Communication error (5012)”

    Thanks, this helped.

  3. #3
    Join Date
    Jul 2011
    Beans
    2

    Re: HP Printer gets “Device Communication error (5012)”

    Thanks so much for this tip, I ran thru all the problems (backend failed, jobs in held state, device comm error,etc). Uninstalled and reinstalled hplip, still not working. Finally reinstalled hplip again, went thru the HP device manager (toolbox) where I had to first connect via usb. Problem seems to be that after the setup specifying wireless, it still has the uri as usb. So after the initial setup, deleted the printer and then added again with the hp-setup -i <ip address> ... so now I am in business and printing from 12.04 to my Deskjet 3520.

  4. #4
    Join Date
    Aug 2007
    Beans
    685
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: HP Printer gets “Device Communication error (5012)”

    I made a mistake in the directions in Post #1 for the printer and fax URI. The printer URI should be "hp:/net/Photosmart_C6100_series?ip=192.168.0.31" (no quotes). If you set up the printer/fax with hp-toolbox, this URI needs to be edited into the Device URI setting using system-config-printer. Likewise "hpfax:/net/Photosmart_C6100_series?ip=192.168.0.31" needs to be edited into the fax Device URI using system-config-printer.

  5. #5
    Join Date
    May 2013
    Beans
    1

    Re: HP Printer gets “Device Communication error (5012)”

    I have spent days trying to figure out why I could only print with a USB cable to my HP 3520 printer. I deleted the printer after set up, entered the command hp-setup -i <ip address>, and it did the trick for me. Tanks for the tip!

  6. #6
    Join Date
    Apr 2010
    Beans
    5

    Re: HP Printer gets “Device Communication error (5012)”

    Thanks David for this post. I always have this hp error and it really helps to have this reference to fix it.

  7. #7
    Join Date
    Jan 2014
    Beans
    4

    Re: HP Printer gets “Device Communication error (5012)”

    If any of you are using a Netgear R7000 Nighthawk router, there is a firmware upgrade that fixes this issue for Macs as well as Ubuntu machines. The troubleshooting that cinched it for me was an inability to ping the printer. After the firmware update, all is well.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •