Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 48

Thread: Using Bluetooth GPS

  1. #31
    Join Date
    Jan 2007

    Re: Using Bluetooth GPS

    I have two problems with this plus one annoyance.

    Firstly, this does work for me but I have to run the

    $ rfcomm connect 0

    command, then kill it with ^C and then run it again. It never works the first time and always works the second time. Any suggestions?

    However, running gpsd automatically fills up my logs with crap if the gps receiver is off. After about three hours I have >3GB of gpsd warnings in two separate log files. Considering that my laptop has a tiny 8GB SSD, this is a serious problem so I have to start gpsd manually.

    Is there some way of starting all this automatically (this is the annoyance) so that the rfcomm connect command and then gpsd are run when the gps receiver is on and in range?

  2. #32
    Join Date
    Jan 2010

    Re: Using Bluetooth GPS

    Quote Originally Posted by Thalarse View Post
    Unfortunately this doesn't seem to work for me.

    The gps receiver shows up on hcitool scan as "00:0A:3A:25:7E:BD BT GPS"
    But when I do the sdptool browser I get "Browsing 00:0A:3A:25:7E:BD ..." And that's it.
    sdptool browse --l2cap 00:11:22:33:44:55

    That worked with my GPS when sdptool browser gave that same what you said.

    I think I've got the wrong channel, perhaps, but I'm not sure. I don't know how to get the info out of the bluetooth receiver any other way.
    Check what that sdptool browse -l2cap says and try that channel.

    I had problems with backtrack linux and nokia bluetooth gps and I wrote short "tutorial" about that: maybe it helps you?

  3. #33
    Join Date
    Oct 2005

    Re: Using Bluetooth GPS

    resurrecting a bit of old thread here - strange problem, blue tooth gps dongle is connected and working fine, xgps and gpspipe -r both receive data and function. However im finding no other program seems to want to work, specificly GmapCatcher and gpsdrive... Both appear to indicate the gps is unavailable but I can't find any further information on it.

    This is how im currently starting the gps:

    sudo service gpsd stop
    sudo rfcomm connect 4
    sudo gpsd -D 5 -nN /dev/rfcomm4
    Followed all of the normal guides, the only thing I can seem to remember is in 9.10 having a similar problem (now running 10.04), and perhaps todo with permissions. Other than that im at a loss.

  4. #34
    Join Date
    Sep 2009
    Ubuntu 10.04 Lucid Lynx

    Re: Using Bluetooth GPS

    I followed the instructions in this guide but didn't get data from the gps although connection was established. xgps reported "gpsd stopped sending data" after a while.

    When I made the connection with the commands Gorlist describes it works with both xgps and Navit!

  5. #35
    Join Date
    Jan 2010

    Question Re: Using Bluetooth GPS

    Hi! Thanks for the great howto!
    I got stuck at a late step:
    rfcomm connect 4
    did not work (permission denied), but
    sudo rfcomm connect 4
    did work.
    So I used the latter plus this. (Idea from
     chown me:me /dev/rfcomm4
    No error here.
    gpsd /dev/rfcomm4
    The command seems to complete without any error.

    However, xgps displays nothing; gpsdrive says "no gps".
    Any ideas?

  6. #36
    Join Date
    May 2007
    College Park
    Ubuntu 10.04 Lucid Lynx

    Re: Using Bluetooth GPS

    I think i'm beating a goat w/ an old stone or horse with a stick or however you say it but I figured I would give it a try.

    So I went through many different tutorials to setup all my bluetooth stuff. Well I have a connection now.

    sudo cat /etc/rfcomm4
    I get stuff like
    So i'm obviously getting data in but none of the programs can read it (xgps, tangogps...)

    I'm hoping I missed something simple. Anyone have any ideas?

  7. #37
    Join Date
    Sep 2006
    Ubuntu 11.04 Natty Narwhal

    Re: Using Bluetooth GPS

    This is correct raw gps (NMEA) data that all gps-units receive. So search for a program to parse that.

    i.e. all programs use this through their own or a 3rd party api.

    Use keyword NMEA in the ubuntu software center. I don't have any gps-units to test atm.
    Last edited by gvoima; July 2nd, 2010 at 12:10 AM.
    "Software is like sex, it's better when it's free." ~Torvalds

  8. #38
    Join Date
    Jul 2010

    Re: Using Bluetooth GPS

    Hi. I'm new to forum and Ubuntu. I went to all the steps from this howto. Many thanks for that.
    At the end I got some mess coming form the GPS. xgps tells that it's connected at 4800bps. I'm sure that my GSpace GS-R238 works at 38400. How to make rfcomm connect at correct speed?

  9. #39
    Join Date
    Jul 2010

    Re: Using Bluetooth GPS

    I think I got it!
    Something has happened to GPS itself. I did factory reset on it and it works fine now.

  10. #40
    Join Date
    Apr 2009

    Post Re: Using Bluetooth GPS

    Ok. This is the solution I have for Ubuntu 10.04 LTS through VMWare Fusion 2.0.7 on a MacBook Pro with a Globalsat BT-338 bluetooth unit.

    Download bluez-utils, gpsd and gpsd-clients

    sudo apt-get install bluez-utils
    sudo apt-get install gpsd-clients
    sudo apt-get install gpsd


    sudo gedit /etc/bluetooth/hcid.conf

    This is what my hcid.conf looks like. Paste it in and save it

    # HCI daemon configuration file.

    # HCId options
    options {
    # Automatically initialize new devices
    autoinit yes;

    # Security Manager mode
    # none - Security manager disabled
    # auto - Use local PIN for incoming connections
    # user - Always ask user for a PIN
    security none;

    # Pairing mode
    # none - Pairing disabled
    # multi - Allow pairing with already paired devices
    # once - Pair once and deny successive attempts
    pairing multi;

    # PIN helper
    pin_helper /usr/bin/bluepin;

    # D-Bus PIN helper

    # Default settings for HCI devices
    device {
    # Local device name
    # %d - device id
    # %h - host name
    name "My Laptop Ubuntu";

    # Local device class
    class 0x3e0100;

    # Default packet type
    #pkt_type DH1,DM1,HV1;

    # Inquiry and Page scan
    iscan enable; pscan enable;

    # Default link mode
    # none - no specific policy
    # accept - always accept incoming connections
    # master - become master on incoming connections,
    # deny role switch on outgoing connections
    lm accept;

    # Default link policy
    # none - no specific policy
    # rswitch - allow role switch
    # hold - allow hold mode
    # sniff - allow sniff mode
    # park - allow park mode
    lp rswitch,hold,sniff,park;

    # Authentication and Encryption (Security Mode 3)
    #auth enable;
    #encrypt enable;

    Save it. I then rebooted as the init.d restart command didn't work

    Turn the GPS unit on

    hcitool scan

    Note the MAC address of the bluetooth unit

    sdptool search SP

    Note the channel number

    sudo gedit /etc/bluetooth/rfcomm.conf

    Paste the following at the end of the file, and save the file.

    rfcomm4 {
    bind yes;
    device < GPS MAC ADDRESS>;
    channel <CHANNEL NUMBER>;
    comment "Serial Port";

    I then found that to connect reliably switch the order of gpsd and rfcomm commands worked

    sudo gpsd -b /dev/rfcomm4
    sudo rfcomm bind rfcomm4

    Then run cgps or xgps or whatever you have to look at the GPS data

    To disconnect

    sudo killall gpsd
    sudo rfcomm release 4

    To reconnect

    sudo gpsd -b /dev/rfcomm4
    sudo rfcomm bind rfcomm4

    And that only took about 18 hours of pissing about and I've had to type it in twice because this forum timed out my login the first time. So I hope someone finds it useful.

    PS. Thanks to NinoCass for the bulk of my solution.
    Last edited by mattbrook; August 1st, 2010 at 03:16 PM.

Page 4 of 5 FirstFirst ... 2345 LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts