Results 1 to 4 of 4

Thread: Precise: How to set default soundcard in pulseaudio?

Hybrid View

  1. #1
    Join Date
    Jan 2006
    Location
    Istanbul
    Beans
    394
    Distro
    Xubuntu 12.04 Precise Pangolin

    Precise: How to set default soundcard in pulseaudio?

    I'm struggling to make pulseaudio understand that my preferred soundcard is usb audio. For which I edited the /etc/modprobe.d/asound.conf and changed indexes that usb audio always gets the index 0 but pulse doesn't take that into account. padevchooser is not installable because of dependency problems. I can change individual application settings and configure them to play with usb audio but how can i tell pulseaudio that I want ALL audio to be routed to usb audio sink? Is this ought to be that hard? In 2012?
    ____________________ooOOoo____________________
    GREETINGS FROM ISTANBUL
    ____________________ooOOoo____________________


  2. #2
    Join Date
    Aug 2009
    Location
    Under the stairs.
    Beans
    1,408
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Precise: How to set default soundcard in pulseaudio?

    Install pavucontrol which is a volume control for pulse but also allows you to choose the fallback or default...
    Dell Inspiron 1764 Laptop, Intel CoreTM i5 520M), 4GB Shared Dual Channel DDR3 at 1066MHz, 512MB ATI Mobility RadeonTM HD4330 Integrated Intel HD.

  3. #3
    Join Date
    Jan 2006
    Location
    Istanbul
    Beans
    394
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Precise: How to set default soundcard in pulseaudio?

    i set the usb audio as fallback in pavucontrol but every newly run application is routed to my PCI card. I've to manually set them in playback tab.
    ____________________ooOOoo____________________
    GREETINGS FROM ISTANBUL
    ____________________ooOOoo____________________


  4. #4
    Join Date
    Sep 2011
    Location
    Minecraftia
    Beans
    Hidden!

    Re: Precise: How to set default soundcard in pulseaudio?

    Not trying to commit necromancy hear, but it isn't that old (in my opinion), still needs an answer, and I found this page while experiencing the same problem, so it's likely others will too.

    Anyhoo - I was having a problem where every new application I used had to either be manually switched from my integrated audio to my pci card in pavucontrol the first time I used it, or couldn't be switched at all.
    I solved this by opening the configuration tab in pavucontrol, and choosing "off" in the dropdown menu for every option that I didn't want (in my case, I set hdmi and integrated sound to "off"). This forces programs to use my preferred choice, my sound card.
    Also, I don't know if it is necessary or not, but I made sure that my preferred choice was set as fallback as well.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •