Results 1 to 2 of 2

Thread: PEAP/MSCHAPv2 wifi connection problems

  1. #1
    Join Date
    Sep 2011
    Beans
    8

    PEAP/MSCHAPv2 wifi connection problems

    I've been searching the net for weeks and still can't find an answer or work around for this:

    When trying to connect to my university's wifi, or eduroam, I can connect for a few minutes, usually a max of five, then the connection shuts down and I'm booted off the network and cannot reconnect. When it was connected, I tried pinging a few websites, and it is connected, but then abruptly stops.

    As usually, the uni's IT department is useless with linux. I use a Broadcom 43xx card, with the STA driver. I've tried it without the driver as well and same problem, running 12.04. The same problem arises when I switch and use the gnome-shell as well.

    I've tried a lot of things, I'm more than willing to retry or change any configuration, really, anything. I hate to say it, but this is a make or break thing for me on Ubuntu, and any other university student as well, I suspect. Does anyone know where the issue lies and/or how to fix it?

    EDIT: A set-up a wifi tether through my Galaxy S2 and the same situation occurs, with the exception that the connection lasts longer, approximately 20 mins each.
    Last edited by aciddesir; June 6th, 2012 at 03:24 PM. Reason: additional info

  2. #2
    Join Date
    Jul 2012
    Beans
    1

    Re: PEAP/MSCHAPv2 wifi connection problems

    Are you using 802.11n? I'm having similar problems and after searching around for a while, it seems that it could be a problem with 802.11n. I would recommend trying to disable 802.11n on your wireless card, typically done using a kernel module configuration file in /etc/modprobe.d.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •