Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: File sharing on xubuntu

  1. #1
    Join Date
    Jan 2011
    Beans
    7

    File sharing on xubuntu

    I can't figure out how to share files between two computers. I would expect that I can simply right click on the folder and make it a share folder, but there is no option in xubuntu 10.10
    I looked on the Internet and someone suggested Application > System > Folder Sharing, but this also doesn't exist.
    Does anyone knows how to do it. This is a basic thing it should be easy to do I think.
    Thanx, Rob

  2. #2
    Join Date
    Feb 2011
    Beans
    204

    Re: File sharing on xubuntu

    I don't know, but I have exactly the same problem. Did you manage tod o that since then?
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  3. #3
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: File sharing on xubuntu

    Folder sharing, like it exists in ubuntu, doesn't exist in OOB xubuntu. One option is to install system-config-samba (along with samba) and use it to set up file sharing. Here's a quick how-to:

    1. Install samba and system-config-samba from the software centre or from the command line:
    Code:
    sudo apt-get install samba system-config-samba
    2. Fireup system-config-samba. Look for it under the System submenu (titled "Samba")

    3. Create the share (File->Add Share or click the plus icon):
    - Directory = select directory to share
    - Share name = share name
    - Description = description
    - Writable = to allow users to write to directory
    - Visible = to make the share visible while browsing
    - Access tab = select who should have access to the share

    4. If you have a firewall active, make sure you allow through the samba ports. If using ufw, then from the command line:
    Code:
    sudo ufw status verbose
    ...if the status is enabled and ports 137/udp, 138/udp, 139/tcp, 445/tcp are not allowed through, issue the follow command:
    Code:
    sudo ufw allow samba
    ...then check to see that all is okay
    Code:
    sudo ufw status verbose
    Otherwise check using your firewall tool.

    5. Connect to the share from other computers.
    Last edited by Toz; October 23rd, 2011 at 07:47 PM.

  4. #4
    Join Date
    Feb 2011
    Beans
    204

    Re: File sharing on xubuntu

    Quote Originally Posted by Toz View Post
    Folder sharing, like it exists in ubuntu, doesn't exist in OOB xubuntu. One option is to install system-config-samba (along with samba) and use it to set up file sharing. Here's a quick how-to:

    1. Install samba and system-config-samba from the software centre or from the command line:
    Code:
    sudo apt-get install samba system-config-samba
    2. Fireup system-config-samba. Look for it under the System submenu (titled "Samba")

    3. Create the share (File->Add Share or click the plus icon):
    - Directory = select directory to share
    - Share name = share name
    - Description = description
    - Writable = to allow users to write to directory
    - Visible = to make the share visible while browsing
    - Access tab = select who should have access to the share

    4. If you have a firewall active, make sure you allow through the samba ports. If using ufw, then from the command line:
    Code:
    sudo ufw status verbose
    ...if the status is enabled and ports 137/udp, 138/udp, 139/tcp, 445/tcp are not allowed through, issue the follow command:
    Code:
    sudo ufw allow samba
    ...then check to see that all is okay
    Code:
    sudo ufw status verbose
    Otherwise check using your firewall tool.

    5. Connect to the share from other computers.
    I did all that with Samba. The only way I can connect to my Xubuntu is via a ftp client on the other computer. It doesn't appear automatically in the scanned networks, nor via the usual afp before the IP address. My other computer is a mac. I don't know if I should use NFS, but I have several nfs-stuff installed and nothing happens.
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  5. #5
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: File sharing on xubuntu

    Is the samba service running? What does the following say?
    Code:
    sudo service smbd status

  6. #6
    Join Date
    Feb 2011
    Beans
    204

    Re: File sharing on xubuntu

    Quote Originally Posted by Toz View Post
    Is the samba service running? What does the following say?
    Code:
    sudo service smbd status
    The output was:

    smbd start/running, process 575
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  7. #7
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: File sharing on xubuntu

    Another way? Install Nautilus on your Xubuntu box, make it the default, open it then click 'Network' in the left panel. You will see all machines on the network (and be able to connect with any of their shared folders/partitions).

    I have static IPs on all my machines which makes life a lot easier (for me at least). For the other boxes (I presume yours are running Ubuntu), Places>Connect to server. I have ssh installed so I choose ssh from the drop down list, insert the IP address of the Xubuntu box, you'll be asked for username and password (for the Xubuntu box), insert them and you're there.

  8. #8
    Join Date
    Feb 2011
    Beans
    204

    Re: File sharing on xubuntu

    Quote Originally Posted by Bucky Ball View Post
    make it the default
    How-to?
    For the other boxes (I presume yours are running Ubuntu
    They are running Mac OS X ...
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

  9. #9
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: File sharing on xubuntu

    To continue with the system-config-suggestion, make sure that they are talking using the same protocol. If you've configured samba on ubuntu, make sure the mac has the smb protocol enabled. I'm not mac expert, but as far as I know, the afp protocol won't connect to a samba share.

  10. #10
    Join Date
    Feb 2011
    Beans
    204

    Re: File sharing on xubuntu

    Quote Originally Posted by Toz View Post
    To continue with the system-config-suggestion, make sure that they are talking using the same protocol. If you've configured samba on ubuntu, make sure the mac has the smb protocol enabled. I'm not mac expert, but as far as I know, the afp protocol won't connect to a samba share.
    Well, although the Xubuntu doesn't automatically appear on the Mac's list of networks, I can connect to using afp://ip.add.ress !

    I don't know if it was because of the Samba configuration, the installation of Nautilus with the sharing permissions of my home folder enabled, the installing of some nfs tools (which I have not even configured)... but it works. I just have to choose the option "connect to server" on my Mac's Finder and it will connect (I have it on my my favorite servers list, so it's quick).

    I just ask myself why it doesn't automatically appear the network list of the Finder... but never mind.

    Another question: how do you enable screen sharing so that the other computer(s) can connect to your Xubuntu screen?
    Linux Mint 17.3 running on my AMD A8-6600K desktop; .Ubuntu 15.10 running on a Intel i5 6200U @2.30 GHz laptop

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •