Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Webcam not working on skype - ubuntu 12.04

  1. #1
    Join Date
    Feb 2012
    Beans
    29

    Webcam not working on skype - ubuntu 12.04

    Webcam is not working on skype with Ubuntu 12.04
    I have a Creative Instant webcam not working on Skype, in Ubuntu 12.04.
    If I use the Skype icon the program runs, but the webcam is non running.

    By opening a terminal and using:

    Code:
    LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so /usr/bin/skype
    Skype runs and the webcan is ok.

    Closing the terminal, Skype closes regularly.

    How can I launch Skype from the dafault icon?
    Any help to solve my problem will be well accepted.

    Thank you.
    Apanta

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,799
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Webcam not working on skype - ubuntu 12.04

    Hi Apanta.

    You need to set the variable LD_PRELOAD permanent in your environment. You have 2 options:

    1. For personal use (just your user) add this line to your ~/.bashrc
    Code:
    export LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so
    2. For system-wide, add this line to your /etc/environment
    Code:
    LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so
    Then restart your machine.

    If you want to read more about this, take a look at this tutorial. Specially the section called 'Persistent environment variables'.


    I hope that helps, and tell us how it goes.
    Regards.

  3. #3
    Join Date
    Feb 2012
    Beans
    29

    Re: Webcam not working on skype - ubuntu 12.04

    Thanks.
    I'll try to solve.
    Regards

    Apanta

  4. #4
    Join Date
    Feb 2012
    Beans
    29

    Re: Webcam not working on skype - ubuntu 12.04

    Sorry,
    How can I find: ~/.bashrc

    If I type :

    Code:
    ~/.bashrc
    the output is:

    Code:
    apanta@apanta-desktop:~$ sudo ~/.bashrc
    sudo: /home/apanta/.bashrc: command not found
    apanta@apanta-desktop:
    how can I make the change?

    Waiting for step by step instructions ( open a terminal, type this ....)
    thanks.
    sorry for my bad english.

    Apanta

  5. #5
    Join Date
    May 2012
    Beans
    44

    Re: Webcam not working on skype - ubuntu 12.04

    Hi Apanta,
    I think that .bashrc is a hidden file that you can find in your home. I'm a newbie myself so don't take what I say as something you should do it's just a suggestion, but I think that you have to edit the .bashrc file so I think you should open a terminal and type
    Code:
    sudo nano /.bashrc
    or
    Code:
    sudo gedit /.bashrc
    and then add the line Papibe wrote in his post.
    Last edited by Toporagno; May 22nd, 2012 at 01:21 PM.

  6. #6
    Join Date
    Feb 2012
    Beans
    29

    Re: Webcam not working on skype - ubuntu 12.04

    Quote Originally Posted by Toporagno View Post
    Hi Apanta,
    I think that .bashrc is a hidden file that you can find in your home. I'm a newbie myself so don't take what I say as something you should do it's just a suggestion, but I think that you have to edit the .bashrc file so I think you should open a terminal and type
    Code:
    sudo nano /.bashrc
    or
    Code:
    sudo gedit /.bashrc
    and then add the line Papibe wrote in his post.
    Hi.
    from terminal, giving the command:

    Code:
    sudo gedit ~/.bashrc
    I see the ~/.bashrc file.

    Inside this file, there is:

    # ~/.bashrc: executed by bash(1) for non-login shells.
    # see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
    # for examples

    # If not running interactively, don't do anything
    [ -z "$PS1" ] && return

    # don't put duplicate lines or lines starting with space in the history.
    # See bash(1) for more options
    HISTCONTROL=ignoreboth

    # append to the history file, don't overwrite it
    shopt -s histappend

    # for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
    HISTSIZE=1000
    HISTFILESIZE=2000

    # check the window size after each command and, if necessary,
    # update the values of LINES and COLUMNS.
    shopt -s checkwinsize

    # If set, the pattern "**" used in a pathname expansion context will
    # match all files and zero or more directories and subdirectories.
    #shopt -s globstar

    # make less more friendly for non-text input files, see lesspipe(1)
    [ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

    # set variable identifying the chroot you work in (used in the prompt below)
    if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
    fi

    # set a fancy prompt (non-color, unless we know we "want" color)
    case "$TERM" in
    xterm-color) color_prompt=yes;;
    esac

    # uncomment for a colored prompt, if the terminal has the capability; turned
    # off by default to not distract the user: the focus in a terminal window
    # should be on the output of commands, not on the prompt
    #force_color_prompt=yes

    if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
    fi

    if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
    else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
    fi
    unset color_prompt force_color_prompt

    # If this is an xterm set the title to user@host:dir
    case "$TERM" in
    xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
    *)
    ;;
    esac

    # enable color support of ls and also add handy aliases
    if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
    fi

    # some more ls aliases
    alias ll='ls -alF'
    alias la='ls -A'
    alias l='ls -CF'

    # Add an "alert" alias for long running commands. Use like so:
    # sleep 10; alert
    alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

    # Alias definitions.
    # You may want to put all your additions into a separate file like
    # ~/.bash_aliases, instead of adding them here directly.
    # See /usr/share/doc/bash-doc/examples in the bash-doc package.

    if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
    fi

    # enable programmable completion features (you don't need to enable
    # this, if it's already enabled in /etc/bash.bashrc and /etc/profile
    # sources /etc/bash.bashrc).
    if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
    fi
    Where can I add the line Papibe wrote in his post (at the last line... after the last fi ...before fi ... or where?

    Take note that I am an absolute beginner in Ubuntu.

    Thanks
    Apanta

  7. #7
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    7,799
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Webcam not working on skype - ubuntu 12.04

    At the very end will be just fine.

    Regards.

  8. #8
    Join Date
    Nov 2007
    Beans
    450

    Re: Webcam not working on skype - ubuntu 12.04

    Um,

    Why are you using the sudo command? The sudo command is there when you want superuser priviledges. As in you want to edit system files. By using it on a file in your home folder and saving that file as sudo you won't be able to access it as your normal user anymore.

    If you are working in your home folder don't use sudo. So a simple
    Code:
    gedit ~/.bashrc
    or if you prefer
    Code:
    nano ~/.bashrc
    Just in case you might want to check and see if you did change the permissions. Just to make sure

    Code:
    cd  #to get to your home folder
    ls -l  # list everything and see the proper permissions
    ls -l |grep .bashrc   #see the permissions on your .bashrc
    Last edited by whitethorn; May 22nd, 2012 at 09:18 PM.

  9. #9
    Join Date
    May 2007
    Location
    DR
    Beans
    1,345
    Distro
    Ubuntu Development Release

    Re: Webcam not working on skype - ubuntu 12.04

    another way (if you're using unity) is to drag the icon from the dash to the desktop, right click and add the command in properties.
    When close to achieving you quit! If you don't try you failed. Real Winners are not afraid of losing.
    ubuntu newsletter ; Report Papercuts (small annoyances/bugs) ; beginners guide and video http://youtube.com/watch?v=Z0tNpt5RZYI

  10. #10
    Join Date
    Feb 2012
    Beans
    29

    Re: Webcam not working on skype - ubuntu 12.04

    Quote Originally Posted by papibe View Post
    At the very end will be just fine.

    Regards.
    I added the line at the end (after the last fi) and now the end of the file is:

    [QUOTE . /etc/bash_completion
    fi
    export LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so][/QUOTE]

    I saved the file and close all.

    Sorry, Skipe still runnig without webcam.

    other suggestions?.
    Apanta

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •