Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Wifi connects, can't ping router or external, since 12.04

  1. #11
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,754
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi, you can just reboot and the commands will be lost and if you want to test them again just run the commands again when you can not connect.
    Thanks

  2. #12
    Join Date
    Nov 2008
    Location
    England, near London
    Beans
    36
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Wifi connects, can't ping router or external, since 12.04

    Quote Originally Posted by wildmanne39 View Post
    Hi, you can just reboot and the commands will be lost and if you want to test them again just run the commands again when you can not connect.
    Thanks
    Thanks.

    Tried a cold boot, and the problem came back. I ran your commands and everything works fine.

    However, I tried another cold boot (problem came back), and this time I ran just:
    sudo ifconfig wlan0 down
    sudo ifconfig wlan0 up

    ...and wifi worked.

    So I'm a bit lost now! It seems that simply restarting the wifi sorts out the connection problem. On first booting, the network manager icon shows I'm connected, and also identifies it as connected to my home wireless network. Why would switching the connection off then on make any difference?

    I am grateful for your help.

  3. #13
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,754
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi, let's make the change persistent and see if that fixes your issue, if not we can write another config file that should work.
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    Then add one line:
    Code:
    options iwlwifi 11n_disable=1
    save gedit,close.
    Reboot
    Thanks

  4. #14
    Join Date
    Nov 2008
    Location
    England, near London
    Beans
    36
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Wifi connects, can't ping router or external, since 12.04

    Quote Originally Posted by wildmanne39 View Post
    Hi, let's make the change persistent and see if that fixes your issue, if not we can write another config file that should work.
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    Then add one line:
    Code:
    options iwlwifi 11n_disable=1
    save gedit,close.
    Reboot
    Thanks
    Tried this and a cold reboot and..... (drum roll)....
    It's worked!

    Presumably this means my wifi has 802.11n disabled? Hey, if it works, I'm not too bothered - g is still operational.

    Once again, thanks!

  5. #15
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,754
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi, your welcome! please use thread tools at the top of the page to mark the thread solved.
    Thanks

  6. #16
    Join Date
    Nov 2005
    Location
    Finland, Espoo
    Beans
    28
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Wifi connects, can't ping router or external, since 12.04

    Quote Originally Posted by wildmanne39 View Post
    Hi, please try:
    Code:
    sudo ifconfig wlan0 down
    sudo rmmod -f iwlwifi
    sudo modprobe iwlwifi 11n_disable=1
    sudo ifconfig wlan0 up
    does it connect now? this is just for testing so do not reboot if it works we will need to make it permanent.
    Thanks
    Interesting. The commands ifconfig wlan0 down and ifconfig wlan0 up fixed the issue for me at least today.

    It seems that my kernel didn't have the module iwlwifi loaded so it couldn't be unloaded either. I guess my corresponding kernel module would be r8169. I may try troubleshooting this again next weekend, so I'd appreciate if anyone cares to analyze the output of my computer when given wildmanne39's commands:

    Code:
    $ cat /etc/lsb-release; uname -a
    DISTRIB_ID=Ubuntu
    DISTRIB_RELEASE=11.10
    DISTRIB_CODENAME=oneiric
    DISTRIB_DESCRIPTION="Ubuntu 11.10"
    Linux myhostname 3.0.0-19-generic #33-Ubuntu SMP Thu Apr 19 19:05:14 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    $ lspci -nnk | grep -iA2 net
    03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6205 [8086:0085] (rev 34)
            Subsystem: Intel Corporation Centrino Advanced-N 6205 AGN [8086:1311]
            Kernel driver in use: iwlagn
    --
    09:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 03)
            Subsystem: Lenovo Device [17aa:21dd]
            Kernel driver in use: r8169
    $ lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 017: ID 0409:0058 NEC Corp. HighSpeed Hub
    Bus 001 Device 004: ID 147e:1002 Upek 
    Bus 001 Device 005: ID 0a5c:217f Broadcom Corp. Bluetooth Controller
    Bus 002 Device 003: ID 5986:03b4 Acer, Inc 
    Bus 001 Device 018: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
    Bus 001 Device 019: ID 0b33:0700 Contour Design, Inc. 
    $ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11abgn  ESSID:"foobar"  
              Mode:Managed  Frequency:2.462 GHz  Access Point: 00:23:08:CB:CC:28   
              Bit Rate=150 Mb/s   Tx-Power=15 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=70/70  Signal level=-24 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:21550  Invalid misc:483   Missed beacon:0
    
    vmnet1    no wireless extensions.
    
    vmnet8    no wireless extensions.
    
    $ rfkill list all
    0: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no
    1: tpacpi_bluetooth_sw: Bluetooth
            Soft blocked: no
            Hard blocked: no
    2: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    $ lsmod
    Module                  Size  Used by
    ipt_REDIRECT           12549  10 
    xt_tcpudp              12603  10 
    iptable_nat            13229  1 
    nf_nat                 25890  2 ipt_REDIRECT,iptable_nat
    nf_conntrack_ipv4      19716  3 iptable_nat,nf_nat
    nf_conntrack           82342  3 iptable_nat,nf_nat,nf_conntrack_ipv4
    nf_defrag_ipv4         12729  1 nf_conntrack_ipv4
    ip_tables              27473  1 iptable_nat
    x_tables               29846  4 ipt_REDIRECT,xt_tcpudp,iptable_nat,ip_tables
    vmnet                  55617  13 
    vsock                  52475  0 
    vmci                   86575  1 vsock
    vmmon                  80498  0 
    bnep                   18436  2 
    rfcomm                 47946  12 
    parport_pc             36962  0 
    ppdev                  17113  0 
    binfmt_misc            17540  1 
    dm_crypt               23199  0 
    snd_hda_codec_hdmi     32040  1 
    snd_hda_codec_realtek   330815  1 
    arc4                   12529  2 
    joydev                 17693  0 
    uvcvideo               72711  0 
    videodev               93004  1 uvcvideo
    v4l2_compat_ioctl32    17083  1 videodev
    thinkpad_acpi          81819  0 
    nvram                  14413  1 thinkpad_acpi
    tpm_tis                18546  0 
    snd_hda_intel          33390  2 
    snd_hda_codec         104968  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13668  1 snd_hda_codec
    snd_pcm                96714  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    snd_seq_midi           13324  0 
    snd_rawmidi            30547  1 snd_seq_midi
    snd_seq_midi_event     14899  1 snd_seq_midi
    snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
    btusb                  18600  1 
    snd_timer              29991  2 snd_pcm,snd_seq
    iwlagn                314257  0 
    snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    68266  15 snd_hda_codec_hdmi,snd_hda_codec_realtek,thinkpad_acpi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    mac80211              462046  1 iwlagn
    psmouse                73882  0 
    serio_raw              13166  0 
    cfg80211              199630  2 iwlagn,mac80211
    bluetooth             166150  23 bnep,rfcomm,btusb
    rts_pstor             445246  0 
    soundcore              12680  1 snd
    snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
    mei                    41480  0 
    lp                     17799  0 
    parport                46562  3 parport_pc,ppdev,lp
    usbhid                 47198  0 
    hid                    95463  1 usbhid
    i915                  571299  3 
    ahci                   26002  2 
    libahci                26861  1 ahci
    drm_kms_helper         42558  1 i915
    drm                   236290  4 i915,drm_kms_helper
    r8169                  52788  0 
    i2c_algo_bit           13423  1 i915
    wmi                    19256  0 
    video                  19597  1 i915

  7. #17
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,754
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi do what is in post 13 and the 2 places that is says iwlwifi type iwlagn.
    Thanks

  8. #18
    Join Date
    Nov 2005
    Location
    Finland, Espoo
    Beans
    28
    Distro
    Kubuntu 8.04 Hardy Heron

    Re: Wifi connects, can't ping router or external, since 12.04

    Quote Originally Posted by wildmanne39 View Post
    Hi do what is in post 13 and the 2 places that is says iwlwifi type iwlagn.
    Thanks
    Thanks for the help... But it seems that I can't even reproduce the problem right now even though I haven't touched anything under /etc/modprobe.d and I just rebooted the computer. Maybe I'll try something if the problem comes back. Anyway, thanks for your help again.

  9. #19
    Join Date
    Jul 2009
    Beans
    27

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi guys,

    On my end, the problem seems to have solved itself organically. Not sure why, but I'll not mess with it now

  10. #20
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    16,754
    Distro
    Ubuntu Mate 16.04 Xenial Xerus

    Re: Wifi connects, can't ping router or external, since 12.04

    Hi, I hope it lasts but an issue not fixed usually comes back.
    Thanks

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •