Results 1 to 4 of 4

Thread: Ubuntu 11.10 - "Wireless is disabled by hardware switch"?

  1. #1
    Join Date
    Jan 2012

    Angry Ubuntu 11.10 - "Wireless is disabled by hardware switch"?

    My wireless has been working fine until about an hour or two ago. I have a dual-boot Compaq Presario A931NR, with Ubuntu 11.10 running fine on it. I've been using an Ethernet cable and it works as well as the router.

  2. #2
    Join Date
    Nov 2010

    Re: Ubuntu 11.10 - "Wireless is disabled by hardware switch"?

    do you have hardware pin (switch)on your Lappy , then enable it.

    else open BIOS settings and then look at there , the WIFI settings . Its set to OFF . Enable it and try again .
    Dont miss anything even it is small. one small pin is enough to bring down a man.

  3. #3
    Join Date
    Jul 2010

    Re: Ubuntu 11.10 - "Wireless is disabled by hardware switch"?

    This worked for me (on Eee PC Seashell Series):

    There's an odd key right above the ESC on this laptop's keyboard. It has an icon suggesting wireless broadcast just to the right of this special key. This key is only used for Windows so I didn't give it a thought. But finally it must have got pressed by accident today, the first time in a couple years that I've been using this computer a lot.

    So I pressed the odd key, and the error message changed to say the wireless was disabled (but now, not mentioning the hardware switch). Then I could re-enable the wireless, using the standard wireless icon in the Ubuntu tool bar at the top of the page.

    I had tried the simple terminal command:
    sudo rfkill unblock all
    before finding the switch. Of course it didn't work for me, since the switch was the problem. But possibly it was also necessary?

    Of course on your laptop, that wireless on/off-switch might be somewhere else.

  4. #4
    Join Date
    Dec 2011
    The Netherlands
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ubuntu 11.10 - "Wireless is disabled by hardware switch"?

    My laptop has a weired thing with this that you might be experiencing as well:
    If i switch the wireless off with the hw switch and reboot w/o reenabling, it get's caught in a "inbetween" state: HW=off and sw says it's on and gives error. Then i flick the switch and now i have this: HW=on and sw says the receiver is turned off.
    rfkill outputs the states as i expect them so it's a bug in network manager.
    I solved it by turning the wireless on with the hw switch (ignoring that network manager says it's off because rfkill says otherwise) and rebooting: Network manager resets to on and matches the hw state again and all is good again.
    "Everything that has a beginning, has an end." --an unexpectedly wise wallpaper

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts