Results 1 to 2 of 2

Thread: Ubuntu One on Lubuntu

  1. #1
    Join Date
    Mar 2012
    Ubuntu 12.04 Precise Pangolin

    Ubuntu One on Lubuntu

    Hello everyone.

    I use Lubuntu on one desktop and Ubuntu on a laptop. Dropbox is my main cloud syncing service but I have created an Ubuntu One SSO account in order to backup my home folders.

    At first, I was not able to use Ubuntu One on Lubuntu - after installing it from synaptics, when I tried to open it, nothing happens except opening a blank terminal window. I had to do this tweak to make it work on Lubuntu:

    After I done this, the Lubuntu bar icons became distinct and logon screen got somewhat misconfigured, having some non-existing usernames in there, but it still works fine so I didn't care much about it.

    Now I can open Ubuntu One client and sync files with the cloud service, but I have no option in context menu to sync any other folder in Lubuntu. It only works if I add the files and folders to Ubuntu One parent folder.

    Worse than that, it is causing a failure with Deja Dup backup of my home folder. Here it is what comes up on Deja Dup dialog every time I start Lubuntu:

    HTML Code:
    Traceback (most recent call last):
      File "/usr/bin/duplicity", line 1403, in <module>
      File "/usr/bin/duplicity", line 1396, in with_tempdir
      File "/usr/bin/duplicity", line 1247, in main
        action = commandline.ProcessCommandLine(sys.argv[1:])
      File "/usr/lib/python2.7/dist-packages/duplicity/", line 999, in ProcessCommandLine
        globals.backend = backend.get_backend(args[0])
      File "/usr/lib/python2.7/dist-packages/duplicity/", line 158, in get_backend
        return _backends[pu.scheme](pu)
      File "/usr/lib/python2.7/dist-packages/duplicity/backends/", line 74, in __init__
      File "/usr/lib/python2.7/dist-packages/duplicity/", line 323, in iterate
        return fn(*args, **kwargs)
      File "/usr/lib/python2.7/dist-packages/duplicity/backends/", line 160, in create_volume
        import ubuntuone.couch.auth as auth
    ImportError: No module named couch.auth
    Can anyone help me with this? How can I make Ubuntu One sync other folders on Lubuntu? And how to solve this error with Deja Dup backup?

    Any help would be much appreciated.
    Last edited by oslub; May 20th, 2012 at 01:55 AM.

  2. #2
    Join Date
    Mar 2012
    Ubuntu 12.04 Precise Pangolin

    Re: Ubuntu One on Lubuntu

    I forgot to mention that this only started to happen when I upgraded from Lubuntu 11.10 to 12.04.

    Reinstallation of ubuntuone-couch package through synaptics solved it for me. I had to remove it completely and then install again.

    Thread solved.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts