Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: usb 3.0 not working on 12.04

  1. #1
    Join Date
    Nov 2006
    Location
    Buckeye country
    Beans
    1,079
    Distro
    Ubuntu 12.04 Precise Pangolin

    usb 3.0 not working on 12.04

    i added usb_storage to /etc/modules, which seemed to get usb 3.0 to work for a while, but it's not working most of the time. the drive works fine if i plug into a usb 2.0 port. anybody know what's going on with usb 3.0?

    thanks

  2. #2
    Join Date
    May 2008
    Location
    Ontario, Canada
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: usb 3.0 not working on 12.04

    usb 3.0 is backward compatible with usb2.0.
    Support should be build into the kernel. I also have USB 3.0.

    Code:
    lspci | grep USB
    00:12.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:12.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:13.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:13.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    00:14.5 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
    00:16.0 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
    00:16.2 USB Controller: ATI Technologies Inc SB7x0/SB8x0/SB9x0 USB EHCI Controller
    03:00.0 USB Controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
    I am not sure why you had to add it to modules, since mine is loaded by default.
    Use the following command to check if it is loaded when it is not working.

    Code:
    lsmod | grep usb
    usb_storage 56275 1
    If it is not loaded, load using
    Code:
    sudo insmod usb_storage
    Even if it was loaded, remove using
    Code:
    sudo rmmod usb_storage
    and then reload

    What distrobution and version are you using?

    uname -a
    Last edited by vandorjw; May 24th, 2012 at 10:40 PM. Reason: Saw your version as 10.04

  3. #3
    Join Date
    Nov 2006
    Location
    Buckeye country
    Beans
    1,079
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: usb 3.0 not working on 12.04

    device is seen:
    Code:
    tim1204@HP-Desktop:~$ lsusb
    Bus 008 Device 004: ID 1058:0740 Western Digital Technologies, Inc. My Passport 1TB
    usb_storage is loaded, even after removing it and rebooting:
    Code:
    tim1204@HP-Desktop:~$ lspci | grep USB
    usb_storage            49198  0
    i even ran gparted and did a check on all partitions (it has 7, with swap, fat32, many ext4), no change. it mounts every time on usb2, i boot off of it with usb2 just fine, but it only rarely mounts on usb3. if nobody else is having the problem, maybe my usb3 card is bad

  4. #4
    Join Date
    Apr 2007
    Location
    Out in Left Field
    Beans
    1,093
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: usb 3.0 not working on 12.04

    Same problem. My USB 3 drive is sometimes recognized and mounted for a few seconds and then disappears

  5. #5
    Join Date
    Apr 2007
    Location
    Out in Left Field
    Beans
    1,093
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: usb 3.0 not working on 12.04

    Appears that Asmedia controllers may not work with Linux https://bbs.archlinux.org/viewtopic.php?id=139421
    we both seem to use that USB 3 controller. My back USB 3 connections work, just not my front ones

  6. #6
    Join Date
    Nov 2006
    Location
    Buckeye country
    Beans
    1,079
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: usb 3.0 not working on 12.04

    Thanks, that's what i was afraid of, guess I'll get a different card

  7. #7
    Join Date
    Dec 2008
    Beans
    2
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Smile Re: usb 3.0 not working on 12.04

    I found a reference to adding the line

    blacklist uas

    to file /etc/modprobe.d/blacklist.conf

    I did a restart and my usb is working. I would love to know what this did and why it works?


    I found only one reference to this and it was pretty obscure, I almost missed it.

  8. #8
    Join Date
    Nov 2006
    Location
    Buckeye country
    Beans
    1,079
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: usb 3.0 not working on 12.04

    thanks for the info. it didn't work for me, but hopefully it works for others. i think mine is a conflict with an existing usb2 hub...

  9. #9
    Join Date
    May 2012
    Beans
    22

    Re: usb 3.0 not working on 12.04

    Quote Originally Posted by trucken View Post
    I found a reference to adding the line

    blacklist uas

    to file /etc/modprobe.d/blacklist.conf

    I did a restart and my usb is working. I would love to know what this did and why it works?


    I found only one reference to this and it was pretty obscure, I almost missed it.
    Did work for me! Thanks! (Dell Vostro 3360)

    Added later: Not perfect, works after restart though after connecting USB for second time, again USB 2.0
    Last edited by michalt; September 18th, 2012 at 01:08 PM.

  10. #10
    Join Date
    May 2010
    Beans
    89
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: usb 3.0 not working on 12.04

    it worked for me only. After doing a restart, it started again.
    doing a usb-devices showed that the driver was uas and not usb-storage
    HP G42-356TU 4GB-RAM, 500GB-HDD
    DUAL BOOT:
    Primary : KUBUNTU 14.04 (TRUSTY) 64bit
    Secondary : DEEPIN 2014 64 Bit

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •