Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Wireless Drivers [FIRST TIME USER]

  1. #11
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    Yes.

  2. #12
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    I did your steps after getting pool - > restricted - > b - > broadcom etc... and then I received this error:

    Items cannot be installed or removed until the package catalog is repared. Do you want to repair it now?

    I pressed repair and I got this:

    Failed to download package files, check your internet connection.

    Details -> Failed to fetch http://archive.ubuntu.com/etc...

  3. #13
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless Drivers [FIRST TIME USER]

    Failed to download package files, check your internet connection.

    Details -> Failed to fetch http://archive.ubuntu.com/etc...
    It's trying to go on line; you can't do that yet.

    You'll need to copy it to a USB key or similar along with all the dependencies here: http://packages.ubuntu.com/precise/bcmwl-kernel-source

    That assumes you have the latest Ubuntu version 12.04. If not, look on the site and match your version. Find out with the terminal command:
    Code:
    lsb_release -a
    Also, be sure to get the correct package for your architecture; either 32- or 64-bit; referred to as i386 or amd64. Some of the packages may also be in your directory you referred to above.

    The dependencies are all the items with red dots. Once you have them all copied over, we'll proceed.

    Post back if you get stuck.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #14
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    When I open the downloaded (http://packages.ubuntu.com/precise/a...ource/download) file, I get the Items cannot be installed or removed until the package catalog is repaired error in the software center, and it stops me from installing if I press cancel.

    Upon pressing cancel, the install button is shaded out and I cannot click it. If I press repair I get the cannot connect to internet error.

    This is very troublesome .

  5. #15
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless Drivers [FIRST TIME USER]

    We are not going to install the packages with Software Center. Copy the files to your Ubuntu desktop. Open a terminal and change directories to the desktop:
    Code:
    cd Desktop
    Now install the .deb files like this:
    Code:
    sudo dpkg -i bcmwl*.deb
    If it says it can't because it needs a dependency, it will no doubt be one of the other packages you downloaded; install it first:
    Code:
    sudo dpkg -i some_package*.deb
    Keep going till they're all done.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #16
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    Which packages is it that I'm installing? Sorry, I'm very new to this...

  7. #17
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless Drivers [FIRST TIME USER]

    See post #13. Go here: http://packages.ubuntu.com/precise/bcmwl-kernel-source

    Copy the bcmwl-kernel-source that you already have to a USB key. Grab all its dependencies with the red dots:
    dkms
    Dynamic Kernel Module Support Framework

    libc6-dev
    Embedded GNU C Library: Development Libraries and Header Files

    linux-headers-generic [amd64]
    Generic Linux kernel headers
    or linux-headers
    virtual package provided by linux-headers-3.2.0-23, linux-headers-3.2.0-23-generic, linux-headers-3.2.0-23-generic-pae, linux-headers-3.2.0-23-lowlatency, linux-headers-3.2.0-23-lowlatency-pae, linux-headers-3.2.0-23-virtual

    linux-headers-generic-pae [i386]
    Generic Linux kernel headers
    or linux-headers
    virtual package provided by linux-headers-3.2.0-23, linux-headers-3.2.0-23-generic, linux-headers-3.2.0-23-generic-pae, linux-headers-3.2.0-23-lowlatency, linux-headers-3.2.0-23-lowlatency-pae, linux-headers-3.2.0-23-virtual

    linux-libc-dev
    Linux Kernel Headers for development
    Copy them to the USB drive, too. Make sure the linux-headers match your kernel:
    Code:
    uname -r
    For example:
    chili@Think60:~$ uname -r
    3.2.0-24-generic-pae
    So if I were installing linux-headers, I'd need lunux-headers-generic and linux-headers-3.2.0-24-generic-pae.

    Once you have them all on your Ubuntu desktop, install as I outlined above.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #18
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    Thank you very much for your help thus far. I have downloaded the following:

    because I am on 64-bit. I then did

    Code:
    sudo dpkg -i dkms_2.2.0.3-1*.deb
    . I received this error afterwards:

    Code:
    Errors were encountered while processing:
       dkms
    Thank you very much for your help again.

  9. #19
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    23,561
    Distro
    Ubuntu 17.10 Artful Aardvark

    Re: Wireless Drivers [FIRST TIME USER]

    Errors were encountered while processing:
    dkms
    We need to know what error. Dependencies? Version? Architecture? Or...?? Also, you can shorten up the commands with:
    Code:
    sudo dpkg -i dkms*.deb
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #20
    Join Date
    May 2012
    Beans
    33

    Re: Wireless Drivers [FIRST TIME USER]

    The errors start here...
    Code:
    dpkg: dependency problems prevent configuration of dkms:
     dkms depend on patch; however:
    Package patch is noot installed.
    Errors were encountered while processing: 
     dkms

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •